Skip to content
Laskyr

Plugins · atomchat · data as of 2026-11-04

Is Group Chat & Video Chat by AtomChat safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.9)

As of 2026-11-04. 5 issues are on record for older versions; version 1.1.9 or newer fixes all of them that state a fix.

Latest version
1.1.9
Last updated
2026-10-07
Active installs
200+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

AtomChat helps you add group chat (or chatrooms), user to user chat, voice & video calling to your WordPress site. — by Team AtomChat

What to do

  1. Update to the latest version (1.1.9). Anything older than 1.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get atomchat --field=version shows what you run; wp plugin update atomchat updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-1253 · published 2026-03-21

Missing authorization check in Group Chat & Video Chat by AtomChat (1.1.7 and older)

Affected
1.1.7 and older
Fixed in
1.1.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Group Chat & Video Chat by AtomChat plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'atomchat_update_auth_ajax' and 'atomchat_update_layout_ajax' functions in all versions up to, and including, 1.1.7. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update plugin options, including critical settings such as API keys, authentication keys, and layout configurations.

NVD CVE-2026-1253Wordfence advisoryPlugin source

medium 4.3 CVE-2025-31831 · published 2025-04-01

Missing authorization check in Group Chat & Video Chat by AtomChat (1.1.7 and older)

Affected
1.1.7 and older
Fixed in
1.1.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Team AtomChat AtomChat atomchat allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AtomChat: from n/a through <= 1.1.7.

NVD CVE-2025-31831Patchstack advisory

medium 6.5 CVE-2025-31532 · published 2025-03-31

Stored cross-site scripting (XSS) in Group Chat & Video Chat by AtomChat (1.1.8 and older)

Affected
1.1.8 and older
Fixed in
1.1.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Team AtomChat AtomChat atomchat allows Stored XSS.This issue affects AtomChat: from n/a through <= 1.1.8.

NVD CVE-2025-31532Patchstack advisory

medium 5.3 CVE-2023-46606 · published 2025-01-02

Missing authorization check in Group Chat & Video Chat by AtomChat (1.1.4 and older)

Affected
1.1.4 and older
Fixed in
1.1.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Team AtomChat AtomChat atomchat allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AtomChat: from n/a through <= 1.1.4.

NVD CVE-2023-46606Patchstack advisory

medium 6.4 CVE-2024-10232 · published 2024-11-01

Stored cross-site scripting (XSS) in Group Chat & Video Chat by AtomChat (1.1.5 and older)

Affected
1.1.5 and older
Fixed in
1.1.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Group Chat & Video Chat by AtomChat plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's atomchat shortcode in all versions up to, and including, 1.1.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-10232Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Group Chat & Video Chat by AtomChat vulnerability status badge
<a href="https://laskyr.com/plugins/atomchat"><img src="https://laskyr.com/plugins/atomchat/badge.svg" alt="Group Chat & Video Chat by AtomChat vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit