Plugins · astro-booking-engine · data as of 2026-11-04
Is Astro Booking Engine safe? Known vulnerabilities and latest version
- Latest version
- 2.7.0
- Last updated
- 2026-10-08
- Active installs
- 10+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Hotel booking form via Gutenberg block or shortcode, independent from the provider: switch booking engine anytime, your form stays the same. — by Alian Schiavoncini
What to do
- Update to the latest version (2.7.0). Anything older than 1.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get astro-booking-engine --field=version shows what you run; wp plugin update astro-booking-engine updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-10308 · published 2026-08-14
Cross-site request forgery (CSRF) in Astro Booking Engine (1.4.0 and older)
- Affected
- 1.4.0 and older
- Fixed in
- 1.4.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Astro Booking Engine plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.0. This is due to missing nonce validation on the options deletion functionality. This makes it possible for unauthenticated attackers to delete all plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-10308Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-08 — latest release on wordpress.org (2.7.0).
- 2026-08-14 — Cross-site request forgery (CSRF) disclosed (CVE-2025-10308), fixed in 1.4.1.
Get an email when Astro Booking Engine has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Astro Booking Engine (astro-booking-engine) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/astro-booking-engine (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/astro-booking-engine"><img src="https://laskyr.com/plugins/astro-booking-engine/badge.svg" alt="Astro Booking Engine vulnerability status"></a>