Skip to content
Laskyr

Plugins · astra-widgets · data as of 2026-11-04

Is Astra Widgets safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.17)

As of 2026-11-04. 3 issues are on record for older versions; version 1.2.17 or newer fixes all of them that state a fix.

Latest version
1.2.17
Last updated
2026-08-24
Active installs
200,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2+

Quickest solution to add widgets like Address, Social Profiles and List icons on a website built with Astra. — by Brainstorm Force

What to do

  1. Update to the latest version (1.2.17). Anything older than 1.2.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get astra-widgets --field=version shows what you run; wp plugin update astra-widgets updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2025-68497 · published 2025-12-24

Stored cross-site scripting (XSS) in Astra Widgets (1.2.16 and older)

Affected
1.2.16 and older
Fixed in
1.2.17
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Astra Widgets astra-widgets allows Stored XSS.This issue affects Astra Widgets: from n/a through <= 1.2.16.

NVD CVE-2025-68497Patchstack advisory

medium 5.4 CVE-2024-56274 · published 2025-01-07

Stored cross-site scripting (XSS) in Astra Widgets (1.2.15 and older)

Affected
1.2.15 and older
Fixed in
1.2.16
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Astra Widgets astra-widgets allows Stored XSS.This issue affects Astra Widgets: from n/a through <= 1.2.15.

NVD CVE-2024-56274Patchstack advisory

medium 5.4 CVE-2024-50439 · published 2024-10-28

Stored cross-site scripting (XSS) in Astra Widgets (1.2.14 and older)

Affected
1.2.14 and older
Fixed in
1.2.15
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Astra Widgets astra-widgets allows Stored XSS.This issue affects Astra Widgets: from n/a through <= 1.2.14.

NVD CVE-2024-50439Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Astra Widgets vulnerability status badge
<a href="https://laskyr.com/plugins/astra-widgets"><img src="https://laskyr.com/plugins/astra-widgets/badge.svg" alt="Astra Widgets vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit