Plugins · askeet · data as of 2026-11-04
Is Askeet safe? Known vulnerabilities and latest version
- Latest version
- 4.0.0
- Last updated
- 2026-08-06
- Active installs
- fewer than 10
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
The AI analyst for your WooCommerce store. Ask any question in plain language — get answers, charts, and recommendations in 5 seconds. — by 2wstechnologies
What to do
- Update to the latest version (4.0.0). Anything older than 3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get askeet --field=version shows what you run; wp plugin update askeet updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-5651 · published 2026-08-05
SQL injection in Askeet (3.0 and older)
- Affected
- 3.0 and older
- Fixed in
- 3.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Askeet plugin for WordPress is vulnerable to SQL Injection via the 'sql_query' parameter in multiple AJAX actions (askeet_execute_sql_query, askeet_export_all_results) in all versions up to, and including, 3.0. This is due to the askeet_is_safe_query() filter being bypassable using MySQL conditional comments (e.g., /*!UNION*/). The filter strips regular block comments before checking for forbidden SQL keywords, but MySQL interprets conditional comments as executable code. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-5651Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-08-06 — latest release on wordpress.org (4.0.0).
- 2026-08-05 — SQL injection disclosed (CVE-2026-5651), fixed in 3.1.
Get an email when Askeet has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Askeet (askeet) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/askeet (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/askeet"><img src="https://laskyr.com/plugins/askeet/badge.svg" alt="Askeet vulnerability status"></a>