Skip to content
Laskyr

Plugins · aryo-activity-log · data as of 2026-11-04

Is Activity Log safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.18.0)

As of 2026-11-04. 7 issues are on record for older versions; version 2.14.0 or newer fixes all of them that state a fix.

Latest version
2.18.0
Last updated
2026-10-28
Active installs
200,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Monitor every change on your WordPress site — who did what, when, and where it came from — for a complete audit trail and stronger security. — by Elementor

What to do

  1. Update to the latest version (2.18.0). Anything older than 2.14.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get aryo-activity-log --field=version shows what you run; wp plugin update aryo-activity-log updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-84759 · published 2026-09-02

Cross-site request forgery (CSRF) in Activity Log (2.13.1 and older)

Affected
2.13.1 and older
Fixed in
2.14.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Activity Log <= 2.13.1 versions.

NVD CVE-2026-84759Patchstack advisory

high 7.2 CVE-2024-10788 · published 2024-11-21

Stored cross-site scripting (XSS) in Activity Log (2.11.1 and older)

Affected
2.11.1 and older
Fixed in
2.11.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Activity Log – Monitor & Record User Changes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the event parameters in all versions up to, and including, 2.11.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrative user accesses an injected page.

NVD CVE-2024-10788Wordfence advisoryPlugin source

medium 5.3 CVE-2023-4281 · published 2023-09-25

Security issue in Activity Log (older than 2.8.8)

Affected
older than 2.8.8
Fixed in
2.8.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

This Activity Log WordPress plugin before 2.8.8 retrieves client IP addresses from potentially untrusted headers, allowing an attacker to manipulate its value. This may be used to hide the source of malicious traffic.

NVD CVE-2023-4281WPScan advisory

critical 9.8 CVE-2022-27858 · published 2022-11-08

CSV injection in Activity Log (2.8.3 and older)

Affected
2.8.3 and older
Fixed in
2.8.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

CSV Injection vulnerability in Activity Log Team Activity Log <= 2.8.3 on WordPress.

NVD CVE-2022-27858Patchstack advisory

medium 6.1 CVE-2016-10890 · published 2019-08-21

Cross-site scripting (XSS) in Activity Log (older than 2.3.2)

Affected
older than 2.3.2
Fixed in
2.3.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The aryo-activity-log plugin before 2.3.2 for WordPress has XSS.

NVD CVE-2016-10890wordpress.org

medium 6.1 CVE-2016-10891 · published 2019-08-21

Cross-site scripting (XSS) in Activity Log (older than 2.3.3)

Affected
older than 2.3.3
Fixed in
2.3.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The aryo-activity-log plugin before 2.3.3 for WordPress has XSS.

NVD CVE-2016-10891wordpress.org

medium 6.1 CVE-2018-8729 · published 2018-03-15

Cross-site scripting (XSS) in Activity Log (older than 2.4.1)

Affected
older than 2.4.1
Fixed in
2.4.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

Multiple cross-site scripting (XSS) vulnerabilities in the Activity Log plugin before 2.4.1 for WordPress allow remote attackers to inject arbitrary JavaScript or HTML via a title that is not escaped.

NVD CVE-2018-8729Code change (fix)wordpress.orggithub.comgithub.comexploit-db.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Activity Log vulnerability status badge
<a href="https://laskyr.com/plugins/aryo-activity-log"><img src="https://laskyr.com/plugins/aryo-activity-log/badge.svg" alt="Activity Log vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit