Skip to content
Laskyr

Plugins · aruba-hispeed-cache · data as of 2026-11-04

Is Aruba HiSpeed Cache safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.0)

As of 2026-11-04. 8 issues are on record for older versions; version 3.0.15 or newer fixes all of them that state a fix.

Latest version
3.2.0
Last updated
2026-10-26
Active installs
100,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Aruba HiSpeed Cache interfaces directly with an Aruba hosting platform's HiSpeed Cache service and automates its management. — by Aruba.it Dev

What to do

  1. Update to the latest version (3.2.0). Anything older than 3.0.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get aruba-hispeed-cache --field=version shows what you run; wp plugin update aruba-hispeed-cache updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-15889 · published 2026-09-10

Stored cross-site scripting (XSS) in Aruba HiSpeed Cache (3.0.14 and older)

Affected
3.0.14 and older
Fixed in
3.0.15 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Aruba HiSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Post Content in all versions up to, and including, 3.0.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-15889Wordfence advisoryCode change (fix)

medium 4.3 CVE-2026-1924 · published 2026-04-10

Cross-site request forgery (CSRF) in Aruba HiSpeed Cache (3.0.4 and older)

Affected
3.0.4 and older
Fixed in
3.0.5 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Aruba HiSpeed Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.4. This is due to missing nonce verification on the `ahsc_ajax_reset_options()` function. This makes it possible for unauthenticated attackers to reset all plugin settings to their default values via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-1924Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-23545 · published 2026-02-19

Missing authorization check in Aruba HiSpeed Cache (3.0.4 and older)

Affected
3.0.4 and older
Fixed in
3.0.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Aruba.it Dev Aruba HiSpeed Cache aruba-hispeed-cache allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Aruba HiSpeed Cache: from n/a through <= 3.0.4.

NVD CVE-2026-23545Patchstack advisory

medium 6.5 CVE-2025-11725 · published 2026-02-19

Missing authorization check in Aruba HiSpeed Cache (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Aruba HiSpeed Cache plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability checks on the multiple functions in all versions up to, and including, 3.0.2. This makes it possible for unauthenticated attackers to modify plugin's configuration settings, enable or disable features, as well as enable/disable WordPress cron jobs or debug mode

NVD CVE-2025-11725Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2025-11706 · published 2026-02-19

Reflected cross-site scripting (XSS) in Aruba HiSpeed Cache (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Aruba HiSpeed Cache plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the dbstatus parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2025-11706Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-67913 · published 2026-01-08

Missing authorization check in Aruba HiSpeed Cache (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.0.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Aruba.it Dev Aruba HiSpeed Cache aruba-hispeed-cache allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Aruba HiSpeed Cache: from n/a through < 3.0.3.

NVD CVE-2025-67913Patchstack advisory

medium 4.3 CVE-2024-43119 · published 2024-11-01

Missing authorization check in Aruba HiSpeed Cache (2.0.12 and older)

Affected
2.0.12 and older
Fixed in
2.0.13
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Aruba.It Aruba HiSpeed Cache allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Aruba HiSpeed Cache: from n/a through 2.0.12.

NVD CVE-2024-43119Patchstack advisory

high 7.5 CVE-2023-44983 · published 2023-12-19

Information disclosure in Aruba HiSpeed Cache (2.0.6 and older)

Affected
2.0.6 and older
Fixed in
2.0.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Aruba.It Aruba HiSpeed Cache.This issue affects Aruba HiSpeed Cache: from n/a through 2.0.6.

NVD CVE-2023-44983Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Aruba HiSpeed Cache vulnerability status badge
<a href="https://laskyr.com/plugins/aruba-hispeed-cache"><img src="https://laskyr.com/plugins/aruba-hispeed-cache/badge.svg" alt="Aruba HiSpeed Cache vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit