Skip to content
Laskyr

Plugins · artplacer-widget · data as of 2026-11-04

Is ArtPlacer Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.23.5)

As of 2026-11-04. 5 issues are on record for older versions; version 2.23.3 or newer fixes all of them that state a fix.

Latest version
2.23.5
Last updated
2026-03-20
Active installs
100+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.2.4+

Allow your visitors visualize how artworks look on walls as soon as they land on your website! — by artplacer

What to do

  1. Update to the latest version (2.23.5). Anything older than 2.23.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get artplacer-widget --field=version shows what you run; wp plugin update artplacer-widget updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-24555 · published 2026-01-23

Stored cross-site scripting (XSS) in ArtPlacer Widget (2.23.2 and older)

Affected
2.23.2 and older
Fixed in
2.23.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in artplacer ArtPlacer Widget artplacer-widget allows Stored XSS.This issue affects ArtPlacer Widget: from n/a through <= 2.23.2.

NVD CVE-2026-24555Patchstack advisory

high 8.5 CVE-2025-67517 · published 2025-12-09

SQL injection in ArtPlacer Widget (2.22.9.2 and older)

Affected
2.22.9.2 and older
Fixed in
2.23
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in artplacer ArtPlacer Widget artplacer-widget allows Blind SQL Injection.This issue affects ArtPlacer Widget: from n/a through <= 2.22.9.2.

NVD CVE-2025-67517Patchstack advisory

high 7.5 CVE-2023-7269 · published 2024-07-19

Cross-site request forgery (CSRF) in ArtPlacer Widget (older than 2.21.2)

Affected
older than 2.21.2
Fixed in
2.21.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The ArtPlacer Widget WordPress plugin before 2.21.2 does not have CSRF check in some places, and is missing sanitisation as well as escaping, which could allow attackers to make logged in admin add Stored XSS payloads via a CSRF attack

NVD CVE-2023-7269WPScan advisory

medium 6.5 CVE-2023-7268 · published 2024-07-19

Missing authorization check in ArtPlacer Widget (older than 2.21.2)

Affected
older than 2.21.2
Fixed in
2.21.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The ArtPlacer Widget WordPress plugin before 2.21.2 does not have authorisation check in place when deleting widgets, allowing ay authenticated users, such as subscriber, to delete arbitrary widgets

NVD CVE-2023-7268WPScan advisory

high 8.8 CVE-2023-6373 · published 2024-01-16

Cross-site request forgery (CSRF) in ArtPlacer Widget (older than 2.20.7)

Affected
older than 2.20.7
Fixed in
2.20.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The ArtPlacer Widget WordPress plugin before 2.20.7 does not sanitize and escape the "id" parameter before submitting the query, leading to a SQLI exploitable by editors and above. Note: Due to the lack of CSRF check, the issue could also be exploited via a CSRF against a logged editor (or above)

NVD CVE-2023-6373WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ArtPlacer Widget vulnerability status badge
<a href="https://laskyr.com/plugins/artplacer-widget"><img src="https://laskyr.com/plugins/artplacer-widget/badge.svg" alt="ArtPlacer Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit