Plugins · ar-for-wordpress · data as of 2026-11-04
Is AR for WordPress safe? Known vulnerabilities and latest version
- Latest version
- 8.45
- Last updated
- 2026-10-28
- Active installs
- 300+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Augmented Reality for WordPress lets you showcase 3D models in an interactive viewer and AR on iOS and Android, with no app downloads needed. — by webandprint
What to do
- Update to the latest version (8.45). Anything older than 8.41 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ar-for-wordpress --field=version shows what you run; wp plugin update ar-for-wordpress updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-14327 · published 2026-07-03
Path traversal / file read in AR for WordPress (8.40 and older)
- Affected
- 8.40 and older
- Fixed in
- 8.41 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The AR for WordPress plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 8.40 via the 'file' parameter parameter. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information. Exploitation requires an attacker to first obtain a valid nonce and secure nonce via the publicly accessible ar_get_fresh_nonce and ar_process_user_image nopriv AJAX handlers, and to reproduce the encryption key locally — both steps are fully achievable by an unauthenticated attacker on any default free or unlicensed installation where ar_licence_key is unset.
NVD CVE-2026-14327Wordfence advisoryCode change (fix)Plugin source
critical 9.6 CVE-2025-60156 · published 2025-09-26
Cross-site request forgery (CSRF) in AR for WordPress (8.34 and older)
- Affected
- 8.34 and older
- Fixed in
- 8.35 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in webandprint AR For WordPress ar-for-wordpress allows Upload a Web Shell to a Web Server.This issue affects AR For WordPress: from n/a through <= 8.34.
medium 6.5 CVE-2025-26913 · published 2025-02-25
Cross-site scripting (XSS) in AR for WordPress (7.7 and older)
- Affected
- 7.7 and older
- Fixed in
- 7.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in webandprint AR For WordPress ar-for-wordpress allows DOM-Based XSS.This issue affects AR For WordPress: from n/a through <= 7.7.
low 3.7 CVE-2024-12300 · published 2024-12-13
Missing authorization check in AR for WordPress (7.3 and older)
- Affected
- 7.3 and older
- Fixed in
- 7.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The AR for WordPress plugin for WordPress is vulnerable to unauthorized double extension file upload due to a missing capability check on the set_ar_featured_image() function in all versions up to, and including, 7.3. This makes it possible for unauthenticated attackers to upload php files leveraging a double extension attack. It's important to note the file is deleted immediately and double extension attacks only work on select servers making this unlikely to be successfully exploited.
NVD CVE-2024-12300Wordfence advisoryCode change (fix)Plugin source
critical 10.0 CVE-2024-50496 · published 2024-10-28
Arbitrary file upload in AR for WordPress (6.6 and older)
- Affected
- 6.6 and older
- Fixed in
- 7.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in webandprint AR For WordPress ar-for-wordpress allows Upload a Web Shell to a Web Server.This issue affects AR For WordPress: from n/a through <= 6.6.
Recent activity
- 2026-10-28 — latest release on wordpress.org (8.45).
- 2026-07-03 — Path traversal / file read disclosed (CVE-2026-14327), fixed in 8.41.
- 2025-09-26 — Cross-site request forgery (CSRF) disclosed (CVE-2025-60156), fixed in 8.35.
- 2025-02-25 — Cross-site scripting (XSS) disclosed (CVE-2025-26913), fixed in 7.8.
Get an email when AR for WordPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for AR for WordPress (ar-for-wordpress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by webandprint (2 tracked)
Types found in this plugin: Path traversal and file read (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1) · Missing authorization (1) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ar-for-wordpress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ar-for-wordpress"><img src="https://laskyr.com/plugins/ar-for-wordpress/badge.svg" alt="AR for WordPress vulnerability status"></a>