Skip to content
Laskyr

Plugins · apply-online · data as of 2026-11-04

Is ApplyOnline safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.1.1)

As of 2026-11-04. 6 issues are on record for older versions; version 2.6.8 or newer fixes all of them that state a fix.

Latest version
2.7.1.1
Last updated
2026-09-28
Active installs
2,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Powerful & intuitive plugin to post ads and start receiving applications online. — by Farhan Noor

What to do

  1. Update to the latest version (2.7.1.1). Anything older than 2.6.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get apply-online --field=version shows what you run; wp plugin update apply-online updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-57721 · published 2026-07-01

Missing authorization check in ApplyOnline (2.6.7.6 and older)

Affected
2.6.7.6 and older
Fixed in
2.6.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Reloaded ApplyOnline allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects ApplyOnline: from n/a through 2.6.7.6.

NVD CVE-2026-57721Patchstack advisory

medium 4.3 CVE-2025-22721 · published 2025-01-21

Missing authorization check in ApplyOnline (2.6.7.1 and older)

Affected
2.6.7.1 and older
Fixed in
2.6.7.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Farhan Noor ApplyOnline apply-online allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ApplyOnline: from n/a through <= 2.6.7.1.

NVD CVE-2025-22721Patchstack advisory

medium 4.3 CVE-2023-46080 · published 2025-01-02

Missing authorization check in ApplyOnline (2.5.3 and older)

Affected
2.5.3 and older
Fixed in
2.5.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Farhan Noor ApplyOnline – Application Form Builder and Manager allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ApplyOnline – Application Form Builder and Manager: from n/a through 2.5.3.

NVD CVE-2023-46080Patchstack advisory

medium 4.3 CVE-2024-2036 · published 2024-05-22

Missing authorization check in ApplyOnline (2.6.2 and older)

Affected
2.6.2 and older
Fixed in
2.6.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ApplyOnline – Application Form Builder and Manager plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the aol_modal_box AJAX action in all versions up to, and including, 2.6.2. This makes it possible for authenticated attackers, with subscriber access or higher, to view Application submissions.

NVD CVE-2024-2036Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.1 CVE-2023-45756 · published 2023-10-25

Reflected cross-site scripting (XSS) in ApplyOnline (2.5.2 and older)

Affected
2.5.2 and older
Fixed in
2.5.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Spider Teams ApplyOnline – Application Form Builder and Manager plugin <= 2.5.2 versions.

NVD CVE-2023-45756Patchstack advisory

medium 4.8 CVE-2023-24391 · published 2023-08-10

Stored cross-site scripting (XSS) in ApplyOnline (2.5 and older)

Affected
2.5 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Spider Teams ApplyOnline plugin <= 2.5 versions.

NVD CVE-2023-24391Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ApplyOnline vulnerability status badge
<a href="https://laskyr.com/plugins/apply-online"><img src="https://laskyr.com/plugins/apply-online/badge.svg" alt="ApplyOnline vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit