Plugins · apocalypse-meow · data as of 2026-11-04
Is Apocalypse Meow safe? Known vulnerabilities and latest version
- Latest version
- 23.2.0
- Last updated
- 2026-10-14
- Active installs
- 300+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
A simple, light-weight collection of tools to harden WordPress security and help mitigate common types of attacks. — by Blobfolio
What to do
- Update to the latest version (23.2.0). Anything older than 23.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get apocalypse-meow --field=version shows what you run; wp plugin update apocalypse-meow updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-3523 · published 2026-03-05
SQL injection in Apocalypse Meow (22.1.0 and older)
- Affected
- 22.1.0 and older
- Fixed in
- 23.0.0 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Apocalypse Meow plugin for WordPress is vulnerable to SQL Injection via the 'type' parameter in all versions up to, and including, 22.1.0. This is due to a flawed logical operator in the type validation check on line 261 of ajax.php — the condition uses `&&` (AND) instead of `||` (OR), causing the `in_array()` validation to be short-circuited and never evaluated for any non-empty type value. Combined with `stripslashes_deep()` being called on line 101 which removes `wp_magic_quotes()` protection, attacker-controlled single quotes pass through unescaped into the SQL query on line 298. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-3523Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-14 — latest release on wordpress.org (23.2.0).
- 2026-03-05 — SQL injection disclosed (CVE-2026-3523), fixed in 23.0.0.
Get an email when Apocalypse Meow has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Apocalypse Meow (apocalypse-meow) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/apocalypse-meow (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/apocalypse-meow"><img src="https://laskyr.com/plugins/apocalypse-meow/badge.svg" alt="Apocalypse Meow vulnerability status"></a>