Plugins · anspress-question-answer · data as of 2026-11-04
Is AnsPress safe? Known vulnerabilities and latest version
- Status
- Closed 2026-07-23
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate anspress-question-answer && wp plugin delete anspress-question-answer
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
high 7.1 CVE-2026-65554 · published 2026-08-06
Missing authorization check in AnsPress (4.4.4 only)
- Affected
- 4.4.4 only
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in AnsPress – Question and answer 4.4.4 versions.
medium 4.8 CVE-2023-34374 · published 2023-08-10
Stored cross-site scripting (XSS) in AnsPress (4.3.0 and older)
- Affected
- 4.3.0 and older
- Fixed in
- 4.3.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (editor+) Stored Cross-Site Scripting (XSS) vulnerability in Rahul Aryan AnsPress plugin <= 4.3.0 versions.
Recent activity
- 2026-07-23 — closed on wordpress.org (Security Issue).
- 2026-08-06 — Missing authorization check disclosed (CVE-2026-65554), fix version not stated.
- 2023-08-10 — Stored cross-site scripting (XSS) disclosed (CVE-2023-34374), fixed in 4.3.2.
Get an email when AnsPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for AnsPress (anspress-question-answer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/anspress-question-answer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/anspress-question-answer"><img src="https://laskyr.com/plugins/anspress-question-answer/badge.svg" alt="AnsPress vulnerability status"></a>