Plugins · animation-addons-for-elementor · data as of 2026-11-04
Is Animation Addons safe? Known vulnerabilities and latest version
- Latest version
- 4.2.8
- Last updated
- 2026-10-24
- Active installs
- 10,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Animation Addons: all-in-one Elementor addons pack – GSAP scroll animations, 100+ Elementor widgets, 40+ Elementor 4 Atomic Widgets & 300+ templates. — by Wealcoder
What to do
- Update to the latest version (4.2.8). Anything older than 4.2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get animation-addons-for-elementor --field=version shows what you run; wp plugin update animation-addons-for-elementor updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-15299 · published 2026-07-10
Stored cross-site scripting (XSS) in Animation Addons (2.6.3 and older)
- Affected
- 2.6.3 and older
- Fixed in
- 2.6.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Animation Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'weather_style' and 'move_direction' parameters of the Weather widget in all versions up to, and including, 2.6.3. This is due to insufficient output escaping in the Weather widget's render() function at widgets/weather.php:1246, where both settings values are placed into an HTML class attribute without esc_attr(). Elementor does not server-side validate widget SELECT control values against allowed options on save, so an authenticated attacker with Contributor-level access or above can submit a crafted save_builder AJAX request storing arbitrary values in the _elementor_data post meta. The stored payload renders unescaped on every frontend visit to the affected page (the Weather widget requires an OpenWeatherMap API key to reach the vulnerable output, which is the normal operational state for sites using this widget).
NVD CVE-2026-15299Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2025-8444 · published 2026-06-10
Stored cross-site scripting (XSS) in Animation Addons (4.2.6 and older)
- Affected
- 4.2.6 and older
- Fixed in
- 4.2.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Animation Addons for Elementor – GSAP Powered Elementor Addons & Website Templates plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the multiple parameters in all versions up to, and including, 4.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-8444Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-39702 · published 2026-04-08
Cross-site scripting (XSS) in Animation Addons (2.6.1 and older)
- Affected
- 2.6.1 and older
- Fixed in
- 2.6.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wealcoder Animation Addons for Elementor animation-addons-for-elementor allows DOM-Based XSS.This issue affects Animation Addons for Elementor: from n/a through <= 2.6.1.
medium 6.5 CVE-2025-67540 · published 2025-12-09
Missing authorization check in Animation Addons (2.4.5 and older)
- Affected
- 2.4.5 and older
- Fixed in
- 2.4.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Wealcoder Animation Addons for Elementor animation-addons-for-elementor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Animation Addons for Elementor: from n/a through <= 2.4.5.
medium 4.3 CVE-2024-12340 · published 2024-12-18
Information disclosure in Animation Addons (1.1.6 and older)
- Affected
- 1.1.6 and older
- Fixed in
- 1.1.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Animation Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.1.6 via the 'render' function in widgets/content-slider.php and widgets/tabs.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft Elementor template data.
Recent activity
- 2026-10-24 — latest release on wordpress.org (4.2.8).
- 2026-07-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15299), fixed in 2.6.4.
- 2026-06-10 — Stored cross-site scripting (XSS) disclosed (CVE-2025-8444), fixed in 4.2.7.
- 2026-04-08 — Cross-site scripting (XSS) disclosed (CVE-2026-39702), fixed in 2.6.2.
Get an email when Animation Addons has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Animation Addons (animation-addons-for-elementor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/animation-addons-for-elementor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/animation-addons-for-elementor"><img src="https://laskyr.com/plugins/animation-addons-for-elementor/badge.svg" alt="Animation Addons vulnerability status"></a>