Skip to content
Laskyr

Plugins · analytics-insights · data as of 2026-11-04

Is Analytics Insights safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.4)

As of 2026-11-04. 1 issue is on record for older versions; version 6.4 or newer fixes all of them that state a fix.

Latest version
6.4
Last updated
2026-10-19
Active installs
10,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

A full-featured and entirely free Google Analytics Dashboard plugin for WordPress. Displays stats to help you to better understand your site content. — by Alin Marcu

What to do

  1. Update to the latest version (6.4). Anything older than 6.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get analytics-insights --field=version shows what you run; wp plugin update analytics-insights updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-111820 · published 2026-10-27

Stored cross-site scripting (XSS) in Analytics Insights (6.3.12 and older)

Affected
6.3.12 and older
Fixed in
6.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Analytics Insights – Google Analytics Dashboard for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Page Title in all versions up to, and including, 6.3.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-111820Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Analytics Insights vulnerability status badge
<a href="https://laskyr.com/plugins/analytics-insights"><img src="https://laskyr.com/plugins/analytics-insights/badge.svg" alt="Analytics Insights vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit