Plugins · analogwp-templates · data as of 2026-11-04
Is Style Kits for Elementor safe? Known vulnerabilities and latest version
- Latest version
- 2.7.0
- Last updated
- 2026-10-30
- Active installs
- 10,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Power-up your Elementor workflow with global theme style presets, container-based patterns, and more global design controls. — by AnalogWP
What to do
- Update to the latest version (2.7.0). Anything older than 2.6.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get analogwp-templates --field=version shows what you run; wp plugin update analogwp-templates updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-27364 · published 2026-08-24
Missing authorization check in Style Kits for Elementor (2.6.5 and older)
- Affected
- 2.6.5 and older
- Fixed in
- 2.6.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in Style Kits <= 2.6.5 versions.
medium 6.3 CVE-2026-65484 · published 2026-07-23
Missing authorization check in Style Kits for Elementor (2.6.5 and older)
- Affected
- 2.6.5 and older
- Fixed in
- 2.6.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Broken Access Control in Style Kits <= 2.6.5 versions.
medium 6.4 CVE-2026-6565 · published 2026-05-27
Stored cross-site scripting (XSS) in Style Kits for Elementor (2.5.0 and older)
- Affected
- 2.5.0 and older
- Fixed in
- 2.6.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Style Kits – Advanced Theme Styles for Elementor, Elementor Kits & Elementor Patterns plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the '/wp-json/agwp/v1/tokens/save' endpoint kit title parameter in versions up to, and including, 2.5.0 due to insufficient input sanitization and output escaping in an admin attribute context. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 8.8 CVE-2021-4401 · published 2023-07-01
Cross-site request forgery (CSRF) in Style Kits for Elementor (1.8.0 and older)
- Affected
- 1.8.0 and older
- Fixed in
- 1.8.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Style Kits plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.8.0. This is due to missing or incorrect nonce validation on the update_posts_stylekit() function. This makes it possible for unauthenticated attackers to update style kits for posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2021-4401Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com
Recent activity
- 2026-10-30 — latest release on wordpress.org (2.7.0).
- 2026-08-24 — Missing authorization check disclosed (CVE-2026-27364), fixed in 2.6.6.
- 2026-07-23 — Missing authorization check disclosed (CVE-2026-65484), fixed in 2.6.6.
- 2026-05-27 — Stored cross-site scripting (XSS) disclosed (CVE-2026-6565), fixed in 2.6.0.
Get an email when Style Kits for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Style Kits for Elementor (analogwp-templates) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/analogwp-templates (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/analogwp-templates"><img src="https://laskyr.com/plugins/analogwp-templates/badge.svg" alt="Style Kits for Elementor vulnerability status"></a>