Skip to content
Laskyr

Plugins · anac-xml-viewer · data as of 2026-11-04

Is ANAC XML Viewer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.4)

As of 2026-11-04. 2 issues are on record for older versions; version 1.8.3 or newer fixes all of them that state a fix.

Latest version
1.8.4
Last updated
2026-10-05
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.2

Software per la visualizzazione di dataset XML su tracciato ANAC (ex AVCP -Legge 190/2012 Art 1.32). — by Marco Milesi

What to do

  1. Update to the latest version (1.8.4). Anything older than 1.8.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get anac-xml-viewer --field=version shows what you run; wp plugin update anac-xml-viewer updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2025-64252 · published 2026-01-22

Server-side request forgery (SSRF) in ANAC XML Viewer (1.8.2 and older)

Affected
1.8.2 and older
Fixed in
1.8.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Marco Milesi ANAC XML Viewer anac-xml-viewer allows Server Side Request Forgery.This issue affects ANAC XML Viewer: from n/a through <= 1.8.2.

NVD CVE-2025-64252Patchstack advisory

medium 4.8 CVE-2023-47245 · published 2023-11-16

Stored cross-site scripting (XSS) in ANAC XML Viewer (1.7 and older)

Affected
1.7 and older
Fixed in
1.7.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Marco Milesi ANAC XML Viewer plugin <= 1.7 versions.

NVD CVE-2023-47245Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ANAC XML Viewer vulnerability status badge
<a href="https://laskyr.com/plugins/anac-xml-viewer"><img src="https://laskyr.com/plugins/anac-xml-viewer/badge.svg" alt="ANAC XML Viewer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit