Plugins · amp · data as of 2026-11-01
Is AMP safe? Known vulnerabilities and latest version
- Latest version
- 2.5.5
- Last updated
- 2025-04-10
- Active installs
- 300,000+
- Known issues on record
- 0
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 7.4+
An easier path to great Page Experience for everyone. Powered by AMP. — by Weston Ruter
What to do
- Update to the latest version (2.5.5). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get amp --field=version shows what you run; wp plugin update amp updates it.
Known vulnerabilities
None on record in the sources we check, as of 2026-11-01.
Recent activity
- 2025-04-10 — latest release on wordpress.org (2.5.5).
Get an email when AMP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for AMP (amp) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/amp (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/amp"><img src="https://laskyr.com/plugins/amp/badge.svg" alt="AMP vulnerability status"></a>