Plugins · amazon-auto-links · data as of 2026-11-04
Is Auto Amazon Links safe? Known vulnerabilities and latest version
- Status
- Closed 2025-11-07
- Known issues on record
- 4
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate amazon-auto-links && wp plugin delete amazon-auto-links
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 4 record(s) do not state which versions are affected.
high 7.5 CVE-2025-11451 · published 2025-11-11
Information disclosure in Auto Amazon Links (5.4.3 and older)
- Affected
- 5.4.3 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Auto Amazon Links – Amazon Associates Affiliate Plugin plugin for WordPress is vulnerable to arbitrary files reads in all versions up to, and including, 5.4.3 via the '/wp-json/wp/v2/aal_ajax_unit_loading' RST API endpoint. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information.
medium 6.1 CVE-2024-9349 · published 2024-10-04
Reflected cross-site scripting (XSS) in Auto Amazon Links (5.4.2 and older)
- Affected
- 5.4.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Auto Amazon Links – Amazon Associates Affiliate Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 5.4.2. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-9349Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2023-52175 · published 2024-02-01
Stored cross-site scripting (XSS) in Auto Amazon Links (5.1.1 and older)
- Affected
- 5.1.1 and older
- Fixed in
- 5.1.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Michael Uno (miunosoft) Auto Amazon Links – Amazon Associates Affiliate Plugin allows Stored XSS.This issue affects Auto Amazon Links – Amazon Associates Affiliate Plugin: from n/a through 5.1.1.
medium 5.4 CVE-2023-4482 · published 2023-10-20
Stored cross-site scripting (XSS) in Auto Amazon Links (5.3.1 and older)
- Affected
- 5.3.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Auto Amazon Links plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the style parameter in versions up to, and including, 5.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with contributor access to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2025-11-07 — closed on wordpress.org (Security Issue).
- 2025-11-11 — Information disclosure disclosed (CVE-2025-11451), fix version not stated.
- 2024-10-04 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-9349), fix version not stated.
- 2024-02-01 — Stored cross-site scripting (XSS) disclosed (CVE-2023-52175), fixed in 5.1.2.
Get an email when Auto Amazon Links has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Auto Amazon Links (amazon-auto-links) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/amazon-auto-links (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/amazon-auto-links"><img src="https://laskyr.com/plugins/amazon-auto-links/badge.svg" alt="Auto Amazon Links vulnerability status"></a>