Plugins · alttext-ai · data as of 2026-11-04
Is Alt Text AI safe? Known vulnerabilities and latest version
- Latest version
- 1.10.46
- Last updated
- 2026-10-22
- Active installs
- 20,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Automatically sets the descriptive alt text of your images. Boosts your SEO and accessibility. — by alttextai
What to do
- Update to the latest version (1.10.46). Anything older than 1.10.42 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get alttext-ai --field=version shows what you run; wp plugin update alttext-ai updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-91108 · published 2026-10-03
Missing authorization check in Alt Text AI (1.10.41 and older)
- Affected
- 1.10.41 and older
- Fixed in
- 1.10.42 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Alt Text AI – Automatically generate image alt text for SEO and accessibility plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.10.41. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to overwrite the post_content of any post or page on the site — including content they do not own — with LLM-generated text influenced by attacker-controlled keywords, enabling black-hat SEO manipulation and unauthorized consumption of the site owner's paid AltText.ai API credits. The nonce required to invoke the action is emitted on every admin page including /wp-admin/profile.php, which is accessible to Subscribers, making the nonce trivially obtainable by any authenticated user.
NVD CVE-2026-91108Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-25348 · published 2026-02-19
Missing authorization check in Alt Text AI (1.10.15 and older)
- Affected
- 1.10.15 and older
- Fixed in
- 1.10.18
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in alttextai Download Alt Text AI alttext-ai allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Download Alt Text AI: from n/a through <= 1.10.15.
high 8.8 CVE-2025-46232 · published 2025-04-22
Missing authorization check in Alt Text AI (1.9.93 and older)
- Affected
- 1.9.93 and older
- Fixed in
- 1.9.94
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in alttextai Download Alt Text AI alttext-ai allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Download Alt Text AI: from n/a through <= 1.9.93.
high 8.8 CVE-2024-4847 · published 2024-05-15
SQL injection in Alt Text AI (1.4.9 and older)
- Affected
- 1.4.9 and older
- Fixed in
- 1.5.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Alt Text AI – Automatically generate image alt text for SEO and accessibility plugin for WordPress is vulnerable to generic SQL Injection via the ‘last_post_id’ parameter in all versions up to, and including, 1.4.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2024-4847Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 5.9 CVE-2024-34366 · published 2024-05-06
Stored cross-site scripting (XSS) in Alt Text AI (1.3.4 and older)
- Affected
- 1.3.4 and older
- Fixed in
- 1.3.5
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AltText.Ai Download Alt Text AI allows Stored XSS.This issue affects Download Alt Text AI: from n/a through 1.3.4.
Recent activity
- 2026-10-22 — latest release on wordpress.org (1.10.46).
- 2026-10-03 — Missing authorization check disclosed (CVE-2026-91108), fixed in 1.10.42.
- 2026-02-19 — Missing authorization check disclosed (CVE-2026-25348), fixed in 1.10.18.
- 2025-04-22 — Missing authorization check disclosed (CVE-2025-46232), fixed in 1.9.94.
Get an email when Alt Text AI has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Alt Text AI (alttext-ai) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · SQL injection (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/alttext-ai (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/alttext-ai"><img src="https://laskyr.com/plugins/alttext-ai/badge.svg" alt="Alt Text AI vulnerability status"></a>