Skip to content
Laskyr

Plugins · alma-gateway-for-woocommerce · data as of 2026-11-04

Is Alma safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.8.0)

As of 2026-11-04. 2 issues are on record for older versions; version 5.16.2 or newer fixes all of them that state a fix.

Latest version
6.8.0
Last updated
2026-10-13
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

This plugin adds a new payment method to WooCommerce, which allows you to offer monthly payments to your customer using Alma. — by Alma

What to do

  1. Update to the latest version (6.8.0). Anything older than 5.16.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get alma-gateway-for-woocommerce --field=version shows what you run; wp plugin update alma-gateway-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-24999 · published 2026-02-19

Missing authorization check in Alma (5.16.1 and older)

Affected
5.16.1 and older
Fixed in
5.16.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Alma Alma alma-gateway-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Alma: from n/a through <= 5.16.1.

NVD CVE-2026-24999Patchstack advisory

medium 5.4 CVE-2023-50369 · published 2023-12-14

Stored cross-site scripting (XSS) in Alma (5.1.3 and older)

Affected
5.1.3 and older
Fixed in
5.1.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Alma Alma – Pay in installments or later for WooCommerce allows Stored XSS.This issue affects Alma – Pay in installments or later for WooCommerce: from n/a through 5.1.3.

NVD CVE-2023-50369Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Alma vulnerability status badge
<a href="https://laskyr.com/plugins/alma-gateway-for-woocommerce"><img src="https://laskyr.com/plugins/alma-gateway-for-woocommerce/badge.svg" alt="Alma vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit