Skip to content
Laskyr

Plugins · ali2woo-lite · data as of 2026-11-04

Is AliNext safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.7.5)

As of 2026-11-04. 8 issues are on record for older versions; version 3.5.4 or newer fixes all of them that state a fix.

Latest version
3.7.5
Last updated
2026-11-03
Active installs
4,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

AliNext is an AliExpress Dropshipping Plugin for WooCommerce trusted by 200,000+ stores. Fast import, reviews, pricing rules & automated order ful … — by guru-aliexpress

What to do

  1. Update to the latest version (3.7.5). Anything older than 3.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ali2woo-lite --field=version shows what you run; wp plugin update ali2woo-lite updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2024-37210 · published 2026-06-17

Missing authorization check in AliNext (3.3.5 and older)

Affected
3.3.5 and older
Fixed in
3.3.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ali2woo AliNext allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects AliNext: from n/a through 3.3.5.

NVD CVE-2024-37210Patchstack advisory

medium 4.7 CVE-2025-30859 · published 2025-03-27

Open redirect in AliNext (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.5.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in guru-aliexpress AliNext ali2woo-lite allows Phishing.This issue affects AliNext: from n/a through <= 3.5.1.

NVD CVE-2025-30859Patchstack advisory

medium 6.5 CVE-2024-37214 · published 2024-11-01

Stored cross-site scripting (XSS) in AliNext (3.3.5 and older)

Affected
3.3.5 and older
Fixed in
3.3.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Dropshipping Guru Ali2Woo Lite Exploiting Incorrectly Configured Access Control Security Levels, Stored XSS.This issue affects Ali2Woo Lite: from n/a through 3.3.5.

NVD CVE-2024-37214Patchstack advisory

medium 6.1 CVE-2024-37211 · published 2024-07-22

Reflected cross-site scripting (XSS) in AliNext (3.3.5 and older)

Affected
3.3.5 and older
Fixed in
3.3.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Ali2Woo Team Ali2Woo Lite allows Reflected XSS.This issue affects Ali2Woo Lite: from n/a through 3.3.5.

NVD CVE-2024-37211Patchstack advisory

high 7.1 CVE-2024-37213 · published 2024-07-12

Cross-site request forgery (CSRF) in AliNext (3.4.6 and older)

Affected
3.4.6 and older
Fixed in
3.4.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in guru-aliexpress AliNext ali2woo-lite allows Cross Site Request Forgery.This issue affects AliNext: from n/a through <= 3.4.6.

NVD CVE-2024-37213Patchstack advisoryPatchstack advisory

high 8.8 CVE-2024-37212 · published 2024-06-21

Cross-site request forgery (CSRF) in AliNext (3.3.5 and older)

Affected
3.3.5 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Ali2Woo Ali2Woo Lite.This issue affects Ali2Woo Lite: from n/a through 3.3.5.

NVD CVE-2024-37212Patchstack advisory

medium 6.3 CVE-2024-4450 · published 2024-06-19

Missing authorization check in AliNext (3.3.6 and older)

Affected
3.3.6 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The AliExpress Dropshipping with AliNext Lite plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several functions in the ImportAjaxController.php file in all versions up to, and including, 3.3.6. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform several actions like importing and modifying products. CVE-2024-37210 is likely a duplicate of this issue.

NVD CVE-2024-4450Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-2381 · published 2024-06-19

Arbitrary file upload in AliNext (3.3.5 and older)

Affected
3.3.5 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The AliExpress Dropshipping with AliNext Lite plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the ajax_save_image function in all versions up to, and including, 3.3.5. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2024-2381Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
AliNext vulnerability status badge
<a href="https://laskyr.com/plugins/ali2woo-lite"><img src="https://laskyr.com/plugins/ali2woo-lite/badge.svg" alt="AliNext vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit