Skip to content
Laskyr

Plugins · alex-reservations · data as of 2026-11-04

Is Alex Reservations safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.8)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.4 or newer fixes all of them that state a fix.

Latest version
2.4.8
Last updated
2026-10-28
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.1+

Restaurant reservations under your brand: booking widget, floor plan, WhatsApp & SMS reminders, 0% commission. White label for agencies & groups. — by Alejandro

What to do

  1. Update to the latest version (2.4.8). Anything older than 2.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get alex-reservations --field=version shows what you run; wp plugin update alex-reservations updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2025-12399 · published 2025-11-08

Arbitrary file upload in Alex Reservations (2.2.3 and older)

Affected
2.2.3 and older
Fixed in
2.2.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Alex Reservations: Smart Restaurant Booking plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the /wp-json/srr/v1/app/upload/file REST endpoint in all versions up to, and including, 2.2.3. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2025-12399Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

medium 6.4 CVE-2024-13380 · published 2025-01-30

Stored cross-site scripting (XSS) in Alex Reservations (2.0.5 and older)

Affected
2.0.5 and older
Fixed in
2.2.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Alex Reservations: Smart Restaurant Booking plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'rr_form' shortcode in all versions up to, and including, 2.0.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13380Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Alex Reservations vulnerability status badge
<a href="https://laskyr.com/plugins/alex-reservations"><img src="https://laskyr.com/plugins/alex-reservations/badge.svg" alt="Alex Reservations vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit