Plugins · akismet · data as of 2026-11-01
Is Akismet Anti-spam safe? Known vulnerabilities and latest version
- Latest version
- 5.7.2
- Last updated
- 2026-08-18
- Active installs
- 5+ million
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
The best anti-spam protection to block spam comments and spam in a contact form. The most trusted antispam solution for WordPress and WooCommerce. — by Automattic
What to do
- Update to the latest version (5.7.2). Anything older than 3.1.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get akismet --field=version shows what you run; wp plugin update akismet updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2015-9357 · published 2019-08-28
Cross-site scripting (XSS) in Akismet Anti-spam (older than 3.1.5)
- Affected
- older than 3.1.5
- Fixed in
- 3.1.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The akismet plugin before 3.1.5 for WordPress has XSS.
Recent activity
- 2026-08-18 — latest release on wordpress.org (5.7.2).
- 2019-08-28 — Cross-site scripting (XSS) disclosed (CVE-2015-9357), fixed in 3.1.5.
Get an email when Akismet Anti-spam has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Akismet Anti-spam (akismet) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/akismet (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/akismet"><img src="https://laskyr.com/plugins/akismet/badge.svg" alt="Akismet Anti-spam vulnerability status"></a>