Skip to content
Laskyr

Plugins · ajax-search-for-woocommerce · data as of 2026-11-04

Is FiboSearch safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.34.3)

As of 2026-11-04. 7 issues are on record for older versions; version 1.34.3 or newer fixes all of them that state a fix.

Latest version
1.34.3
Last updated
2026-10-08
Active installs
100,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The most popular WooCommerce product search plugin. Gives your users a well-designed advanced AJAX search bar with live search suggestions. — by Damian Góra

What to do

  1. Update to the latest version (1.34.3). Anything older than 1.34.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ajax-search-for-woocommerce --field=version shows what you run; wp plugin update ajax-search-for-woocommerce updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-100106 · published 2026-10-16

Stored cross-site scripting (XSS) in FiboSearch (1.34.2 and older)

Affected
1.34.2 and older
Fixed in
1.34.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FiboSearch – Ajax Search for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'purchased_plan' parameter in all versions up to, and including, 1.34.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that the site owner has previously completed the standard Freemius opt-in flow; once that condition is met, any Subscriber can reach the vulnerable handler simply by loading /wp-admin/profile.php with the requisite query parameters.

NVD CVE-2026-100106Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-96553 · published 2026-10-09

Reflected cross-site scripting (XSS) in FiboSearch (1.34.1 and older)

Affected
1.34.1 and older
Fixed in
1.34.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Damian Góra FiboSearch ajax-search-for-woocommerce allows Reflected XSS.This issue affects FiboSearch: from n/a through 1.34.1.

NVD CVE-2026-96553Patchstack advisory

medium 5.9 CVE-2026-28179 · published 2026-08-06

Cross-site scripting (XSS) in FiboSearch (1.33.0 and older)

Affected
1.33.0 and older
Fixed in
1.34.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager Cross Site Scripting (XSS) in FiboSearch <= 1.33.0 versions.

NVD CVE-2026-28179Patchstack advisory

medium 5.4 CVE-2025-14298 · published 2025-12-20

Stored cross-site scripting (XSS) in FiboSearch (1.32.0 and older)

Affected
1.32.0 and older
Fixed in
1.32.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FiboSearch – Ajax Search for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `thegem_te_search` shortcode in all versions up to, and including, 1.32.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability requires TheGem theme (premium) to be installed with Header Builder mode enabled, and the FiboSearch "Replace search bars" option enabled for TheGem integration.

NVD CVE-2025-14298Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.3 CVE-2025-47444 · published 2025-08-12

Missing authorization check in FiboSearch (1.32.1 and older)

Affected
1.32.1 and older
Fixed in
1.32.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Damian Góra FiboSearch ajax-search-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FiboSearch: from n/a through <= 1.32.1.

NVD CVE-2025-47444Patchstack advisory

medium 4.4 CVE-2023-2450 · published 2023-06-09

Stored cross-site scripting (XSS) in FiboSearch (1.23.0 only)

Affected
1.23.0 only
Fixed in
1.24.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The FiboSearch - AJAX Search for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 1.23.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2023-2450Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2022-1469 · published 2022-06-08

Stored cross-site scripting (XSS) in FiboSearch (older than 1.17.0)

Affected
older than 1.17.0
Fixed in
1.17.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The FiboSearch WordPress plugin before 1.17.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed

NVD CVE-2022-1469WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FiboSearch vulnerability status badge
<a href="https://laskyr.com/plugins/ajax-search-for-woocommerce"><img src="https://laskyr.com/plugins/ajax-search-for-woocommerce/badge.svg" alt="FiboSearch vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit