Skip to content
Laskyr

Plugins · ai-for-seo · data as of 2026-11-04

Is SOOZ safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.4.3 or newer fixes all of them that state a fix.

Latest version
2.6.1
Last updated
2026-10-27
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

SEO Autopilot that works with Yoast SEO, Rank Math, All in One SEO, WooCommerce etc. to bulk-generate keyphrases, meta tags, alt text and more. — by Space Codes

What to do

  1. Update to the latest version (2.6.1). Anything older than 2.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ai-for-seo --field=version shows what you run; wp plugin update ai-for-seo updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-66459 · published 2026-08-13

Missing authorization check in SOOZ (2.4.2 and older)

Affected
2.4.2 and older
Fixed in
2.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in AI for SEO <= 2.4.2 versions.

NVD CVE-2026-66459Patchstack advisory

medium 4.3 CVE-2025-22299 · published 2025-01-07

Missing authorization check in SOOZ (1.2.9 and older)

Affected
1.2.9 and older
Fixed in
1.2.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Space Codes AI for SEO ai-for-seo allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AI for SEO: from n/a through <= 1.2.9.

NVD CVE-2025-22299Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SOOZ vulnerability status badge
<a href="https://laskyr.com/plugins/ai-for-seo"><img src="https://laskyr.com/plugins/ai-for-seo/badge.svg" alt="SOOZ vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit