Skip to content
Laskyr

Plugins · ai-content-generation · data as of 2026-11-04

Is WP Wand safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.0 or newer fixes all of them that state a fix.

Latest version
2.1.1
Last updated
2026-10-04
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Write posts, product copy and marketing content inside WordPress with your own OpenAI, Claude, OpenRouter or Deepseek key. — by WP Grids

What to do

  1. Update to the latest version (2.1.1). Anything older than 2.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ai-content-generation --field=version shows what you run; wp plugin update ai-content-generation updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-25391 · published 2026-02-19

Missing authorization check in WP Wand (1.3.07 and older)

Affected
1.3.07 and older
Fixed in
2.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Grids WP Wand ai-content-generation allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Wand: from n/a through <= 1.3.07.

NVD CVE-2026-25391Patchstack advisory

medium 5.3 CVE-2025-22302 · published 2025-01-07

Missing authorization check in WP Wand (1.2.5 and older)

Affected
1.2.5 and older
Fixed in
1.2.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Grids WP Wand ai-content-generation allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Wand: from n/a through <= 1.2.5.

NVD CVE-2025-22302Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Wand vulnerability status badge
<a href="https://laskyr.com/plugins/ai-content-generation"><img src="https://laskyr.com/plugins/ai-content-generation/badge.svg" alt="WP Wand vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit