Plugins · ai-co-pilot-for-wp · data as of 2026-11-04
Is WP AI CoPilot safe? Known vulnerabilities and latest version
- Status
- Closed 2026-06-09
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate ai-co-pilot-for-wp && wp plugin delete ai-co-pilot-for-wp
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
medium 5.0 CVE-2025-62998 · published 2025-12-18
Information disclosure in WP AI CoPilot (1.2.7 and older)
- Affected
- 1.2.7 and older
- Fixed in
- 1.2.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in WP Messiah WP AI CoPilot ai-co-pilot-for-wp allows Retrieve Embedded Sensitive Data.This issue affects WP AI CoPilot: from n/a through <= 1.2.7.
medium 4.3 CVE-2025-62994 · published 2025-12-09
Information disclosure in WP AI CoPilot (1.2.7 and older)
- Affected
- 1.2.7 and older
- Fixed in
- 1.2.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in WP Messiah WP AI CoPilot ai-co-pilot-for-wp allows Retrieve Embedded Sensitive Data.This issue affects WP AI CoPilot: from n/a through <= 1.2.7.
Recent activity
- 2026-06-09 — closed on wordpress.org (Guideline Violation).
- 2025-12-18 — Information disclosure disclosed (CVE-2025-62998), fixed in 1.2.8.
- 2025-12-09 — Information disclosure disclosed (CVE-2025-62994), fixed in 1.2.8.
Get an email when WP AI CoPilot has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP AI CoPilot (ai-co-pilot-for-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (2)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/ai-co-pilot-for-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ai-co-pilot-for-wp"><img src="https://laskyr.com/plugins/ai-co-pilot-for-wp/badge.svg" alt="WP AI CoPilot vulnerability status"></a>