Skip to content
Laskyr

Plugins · ai-auto-tool · data as of 2026-11-04

Is Ai Auto Tool Content Writing Assistant All in… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.0)

As of 2026-11-04. 4 issues are on record for older versions; version 2.3.4 or newer fixes all of them that state a fix.

Latest version
2.4.0
Last updated
2026-08-04
Active installs
40+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

AI content writing assistant for WordPress with Gemini, ChatGPT, 9Router, agent workflows, SEO, media, automation, and live models. — by aitool

What to do

  1. Update to the latest version (2.4.0). Anything older than 2.3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ai-auto-tool --field=version shows what you run; wp plugin update ai-auto-tool updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-12156 · published 2025-11-04

Missing authorization check in Ai Auto Tool Content Writing Assistant All in… (2.0.7 to 2.2.6)

Affected
2.0.7 to 2.2.6
Fixed in
2.2.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Ai Auto Tool Content Writing Assistant (Gemini Writer, ChatGPT ) All in One plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_post_data() function in versions 2.0.7 to 2.2.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create and publish arbitrary posts.

NVD CVE-2025-12156Wordfence advisorywordpress.org

medium 4.9 CVE-2025-58829 · published 2025-09-05

Server-side request forgery (SSRF) in Ai Auto Tool Content Writing Assistant All in… (2.3.3 and older)

Affected
2.3.3 and older
Fixed in
2.3.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in aitool Ai Auto Tool Content Writing Assistant (Gemini Writer, ChatGPT ) All in One ai-auto-tool allows Server Side Request Forgery.This issue affects Ai Auto Tool Content Writing Assistant (Gemini Writer, ChatGPT ) All in One: from n/a through <= 2.3.3.

NVD CVE-2025-58829Patchstack advisory

high 8.5 CVE-2025-31564 · published 2025-04-01

SQL injection in Ai Auto Tool Content Writing Assistant All in… (2.2.6 and older)

Affected
2.2.6 and older
Fixed in
2.2.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in aitool Ai Auto Tool Content Writing Assistant (Gemini Writer, ChatGPT ) All in One ai-auto-tool allows Blind SQL Injection.This issue affects Ai Auto Tool Content Writing Assistant (Gemini Writer, ChatGPT ) All in One: from n/a through <= 2.2.6.

NVD CVE-2025-31564Patchstack advisory

high 7.5 CVE-2024-52383 · published 2024-11-14

Missing authorization check in Ai Auto Tool Content Writing Assistant All in… (2.1.2 and older)

Affected
2.1.2 and older
Fixed in
2.1.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in aitool Ai Auto Tool Content Writing Assistant (Gemini Writer, ChatGPT ) All in One ai-auto-tool allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ai Auto Tool Content Writing Assistant (Gemini Writer, ChatGPT ) All in One: from n/a through <= 2.1.2.

NVD CVE-2024-52383Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Ai Auto Tool Content Writing Assistant All in… vulnerability status badge
<a href="https://laskyr.com/plugins/ai-auto-tool"><img src="https://laskyr.com/plugins/ai-auto-tool/badge.svg" alt="Ai Auto Tool Content Writing Assistant All in… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit