Skip to content
Laskyr

Plugins · agile-store-locator · data as of 2026-11-04

Is Agile Store Locator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.9)

As of 2026-11-04. 6 issues are on record for older versions; version 1.6.3 or newer fixes all of them that state a fix.

Latest version
1.8.9
Last updated
2026-10-21
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4

Agile Store Locator is a WordPress store locator and store finder for where-to-buy pages, with free no-key maps and native Google Maps. — by Agile Logix

What to do

  1. Update to the latest version (1.8.9). Anything older than 1.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get agile-store-locator --field=version shows what you run; wp plugin update agile-store-locator updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2025-67516 · published 2025-12-09

SQL injection in Agile Store Locator (1.6.2 and older)

Affected
1.6.2 and older
Fixed in
1.6.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Agile Logix Store Locator WordPress agile-store-locator allows Blind SQL Injection.This issue affects Store Locator WordPress: from n/a through <= 1.6.2.

NVD CVE-2025-67516Patchstack advisory

high 7.6 CVE-2025-49328 · published 2025-06-06

SQL injection in Agile Store Locator (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Agile Logix Store Locator WordPress agile-store-locator allows SQL Injection.This issue affects Store Locator WordPress: from n/a through <= 1.5.1.

NVD CVE-2025-49328Patchstack advisory

medium 6.6 CVE-2025-49329 · published 2025-06-06

Arbitrary file upload in Agile Store Locator (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Agile Logix Store Locator WordPress agile-store-locator allows Upload a Web Shell to a Web Server.This issue affects Store Locator WordPress: from n/a through <= 1.5.2.

NVD CVE-2025-49329Patchstack advisory

medium 6.8 CVE-2023-50885 · published 2024-04-18

Path traversal / file read in Agile Store Locator (1.4.14 and older)

Affected
1.4.14 and older
Fixed in
1.4.15 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in AGILELOGIX Store Locator WordPress.This issue affects Store Locator WordPress: from n/a through 1.4.14.

NVD CVE-2023-50885Patchstack advisory

medium 4.8 CVE-2023-27618 · published 2023-06-22

Stored cross-site scripting (XSS) in Agile Store Locator (1.4.9 and older)

Affected
1.4.9 and older
Fixed in
1.4.10
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (editor+) Stored Cross-Site Scripting (XSS) vulnerability in AGILELOGIX Store Locator WordPress plugin <= 1.4.9 versions.

NVD CVE-2023-27618Patchstack advisory

medium 6.1 CVE-2022-41615 · published 2022-11-18

Cross-site request forgery (CSRF) in Agile Store Locator (1.4.5 and older)

Affected
1.4.5 and older
Fixed in
1.4.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Scripting (XSS) via Cross-Site Request Forgery (CSRF) vulnerability in Store Locator plugin <= 1.4.5 on WordPress.

NVD CVE-2022-41615Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Agile Store Locator vulnerability status badge
<a href="https://laskyr.com/plugins/agile-store-locator"><img src="https://laskyr.com/plugins/agile-store-locator/badge.svg" alt="Agile Store Locator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit