Skip to content
Laskyr

Plugins · aftership-woocommerce-tracking · data as of 2026-11-04

Is AfterShip Tracking safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.18.5)

As of 2026-11-04. 2 issues are on record for older versions; version 1.18.2 or newer fixes all of them that state a fix.

Latest version
1.18.5
Last updated
2026-10-15
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.8.12

Track orders in one place. shipment tracking, automated notifications, order lookup, branded tracking page, delivery day prediction — by AfterShip & Automizely

What to do

  1. Update to the latest version (1.18.5). Anything older than 1.18.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get aftership-woocommerce-tracking --field=version shows what you run; wp plugin update aftership-woocommerce-tracking updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-66460 · published 2026-08-13

Cross-site scripting (XSS) in AfterShip Tracking (1.18.1 and older)

Affected
1.18.1 and older
Fixed in
1.18.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Cross Site Scripting (XSS) in AfterShip Tracking <= 1.18.1 versions.

NVD CVE-2026-66460Patchstack advisory

medium 5.3 CVE-2025-58201 · published 2025-08-27

Missing authorization check in AfterShip Tracking (1.17.17 and older)

Affected
1.17.17 and older
Fixed in
1.17.18
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in AfterShip & Automizely AfterShip Tracking aftership-woocommerce-tracking allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects AfterShip Tracking: from n/a through <= 1.17.17.

NVD CVE-2025-58201Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
AfterShip Tracking vulnerability status badge
<a href="https://laskyr.com/plugins/aftership-woocommerce-tracking"><img src="https://laskyr.com/plugins/aftership-woocommerce-tracking/badge.svg" alt="AfterShip Tracking vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit