Plugins · affiliate-ai-lite · data as of 2026-11-04
Is Affiliate AI Lite safe? Known vulnerabilities and latest version
- Latest version
- 1.1.0
- Last updated
- 2026-10-05
- Active installs
- 30+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Add Amazon affiliate product boxes with blocks, shortcodes or Elementor, with caching and built-in product health diagnostics. — by Rustaurius
What to do
- Update to the latest version (1.1.0). Anything older than 1.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get affiliate-ai-lite --field=version shows what you run; wp plugin update affiliate-ai-lite updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2025-11799 · published 2025-11-21
Stored cross-site scripting (XSS) in Affiliate AI Lite (1.0.1 and older)
- Affected
- 1.0.1 and older
- Fixed in
- 1.0.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Affiliate AI Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'asin' shortcode attribute in the affiai_img shortcode in all versions up to, and including, 1.0.1. This is due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-11799Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-05 — latest release on wordpress.org (1.1.0).
- 2025-11-21 — Stored cross-site scripting (XSS) disclosed (CVE-2025-11799), fixed in 1.0.2.
Get an email when Affiliate AI Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Affiliate AI Lite (affiliate-ai-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Rustaurius (7 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/affiliate-ai-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/affiliate-ai-lite"><img src="https://laskyr.com/plugins/affiliate-ai-lite/badge.svg" alt="Affiliate AI Lite vulnerability status"></a>