Skip to content
Laskyr

Plugins · advanced-settings · data as of 2026-11-04

Is Advanced Settings 3 safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.2)

As of 2026-11-04. 3 issues are on record for older versions; version 3.2.0 or newer fixes all of them that state a fix.

Latest version
3.3.2
Last updated
2026-10-25
Active installs
200+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Adds settings that you might expect to find in the WordPress core. — by Helmut Wandl

What to do

  1. Update to the latest version (3.3.2). Anything older than 3.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-settings --field=version shows what you run; wp plugin update advanced-settings updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.1 CVE-2025-58996 · published 2025-11-06

Arbitrary file upload in Advanced Settings 3 (3.1.1 and older)

Affected
3.1.1 and older
Fixed in
3.2.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Helmut Wandl Advanced Settings advanced-settings allows Upload a Web Shell to a Web Server.This issue affects Advanced Settings: from n/a through <= 3.1.1.

NVD CVE-2025-58996Patchstack advisory

medium 4.3 CVE-2025-58975 · published 2025-09-09

Cross-site request forgery (CSRF) in Advanced Settings 3 (3.1.1 and older)

Affected
3.1.1 and older
Fixed in
3.2.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Helmut Wandl Advanced Settings advanced-settings allows Cross Site Request Forgery.This issue affects Advanced Settings: from n/a through <= 3.1.1.

NVD CVE-2025-58975Patchstack advisory

medium 4.3 CVE-2025-49865 · published 2025-06-17

Cross-site request forgery (CSRF) in Advanced Settings 3 (3.0.1 and older)

Affected
3.0.1 and older
Fixed in
3.0.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Helmut Wandl Advanced Settings advanced-settings allows Cross Site Request Forgery.This issue affects Advanced Settings: from n/a through <= 3.0.1.

NVD CVE-2025-49865Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Settings 3 vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-settings"><img src="https://laskyr.com/plugins/advanced-settings/badge.svg" alt="Advanced Settings 3 vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit