Skip to content
Laskyr

Plugins · advanced-responsive-video-embedder · data as of 2026-11-04

Is Advanced Responsive Video Embedder for Rumble,… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (10.9.5)

As of 2026-11-04. 1 issue is on record for older versions; version 10.8.9 or newer fixes all of them that state a fix.

Latest version
10.9.5
Last updated
2026-10-10
Active installs
20,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Level up your basic video embeds! Advanced features, privacy. Use URLs, Shortcodes or Blocks to customize videos to your needs. — by Nicolas Jonas

What to do

  1. Update to the latest version (10.9.5). Anything older than 10.8.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-responsive-video-embedder --field=version shows what you run; wp plugin update advanced-responsive-video-embedder updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-18072 · published 2026-07-29

Authentication bypass in Advanced Responsive Video Embedder for Rumble,… (10.8.7 only)

Affected
10.8.7 only
Fixed in
10.8.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Responsive Video Embedder for Rumble, Odysee, YouTube, Vimeo, Kick … plugin for WordPress is vulnerable to Authentication Bypass via a Hardcoded Backdoor in version 10.8.7. The vulnerability exists because the `_arve_uc_init()` function — registered on WordPress's `init` hook at priority 1 so that it runs before any authentication checks on every request — reads an attacker-supplied token from the `_wplogin` (or `_wpm`) parameter and compares it against a hardcoded SHA-256 hash embedded directly in the plugin source, with no nonce verification, no capability check, and no password validation anywhere in the flow. Because this static hash constitutes a set of universal credentials that are publicly accessible in the plugin's source code, unauthenticated attackers can supply the known token to be authenticated as an arbitrarily selected existing administrator account, gaining full administrative control over the affected WordPress site. This was likely introduced by an attacker who gained commit access to the developers account.

NVD CVE-2026-18072Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Responsive Video Embedder for Rumble,… vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-responsive-video-embedder"><img src="https://laskyr.com/plugins/advanced-responsive-video-embedder/badge.svg" alt="Advanced Responsive Video Embedder for Rumble,… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit