Skip to content
Laskyr

Plugins · advanced-product-fields-for-woocommerce · data as of 2026-11-04

Is Advanced Product Fields (Product Addons) for W… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.3)

As of 2026-11-04. 4 issues are on record for older versions; version 1.6.22 or newer fixes all of them that state a fix.

Latest version
1.7.3
Last updated
2026-10-30
Active installs
50,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Add options (addons) to your WooCommerce products so your customers can personalize their products. Product forms for everyone! — by Maarten B

What to do

  1. Update to the latest version (1.7.3). Anything older than 1.6.22 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-product-fields-for-woocommerce --field=version shows what you run; wp plugin update advanced-product-fields-for-woocommerce updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-2996 · published 2026-08-22

Security issue in Advanced Product Fields (Product Addons) for W… (1.6.21 and older)

Affected
1.6.21 and older
Fixed in
1.6.22 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.

NVD CVE-2026-2996Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-39499 · published 2026-06-15

PHP object injection in Advanced Product Fields (Product Addons) for W… (1.6.19 and older)

Affected
1.6.19 and older
Fixed in
1.6.20
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager PHP Object Injection in Advanced Product Fields (Product Addons) for WooCommerce <= 1.6.19 versions.

NVD CVE-2026-39499Patchstack advisory

medium 5.3 CVE-2026-32457 · published 2026-03-13

Missing authorization check in Advanced Product Fields (Product Addons) for W… (1.6.18 and older)

Affected
1.6.18 and older
Fixed in
1.6.19
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Wombat Plugins Advanced Product Fields (Product Addons) for WooCommerce advanced-product-fields-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Advanced Product Fields (Product Addons) for WooCommerce: from n/a through <= 1.6.18.

NVD CVE-2026-32457Patchstack advisory

medium 4.3 CVE-2025-13924 · published 2025-12-09

Cross-site request forgery (CSRF) in Advanced Product Fields (Product Addons) for W… (1.6.17 and older)

Affected
1.6.17 and older
Fixed in
1.6.18 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.6.17. This is due to missing or incorrect nonce validation on the 'maybe_duplicate' function. This makes it possible for unauthenticated attackers to duplicate and publish product field groups, including draft and pending field groups, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-13924Wordfence advisoryCode change (fix)github.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Product Fields (Product Addons) for W… vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-product-fields-for-woocommerce"><img src="https://laskyr.com/plugins/advanced-product-fields-for-woocommerce/badge.svg" alt="Advanced Product Fields (Product Addons) for W… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit