Skip to content
Laskyr

Plugins · advanced-post-manager · data as of 2026-11-04

Is Advanced Post Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.5.7)

As of 2026-11-04. 2 issues are on record for older versions; version 4.5.7 or newer fixes all of them that state a fix.

Latest version
4.5.7
Last updated
2026-10-15
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Turbo charge your posts admin for any custom post type with sortable filters and columns, and auto-registration of metaboxes. — by Nexcess

What to do

  1. Update to the latest version (4.5.7). Anything older than 4.5.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-post-manager --field=version shows what you run; wp plugin update advanced-post-manager updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-111396 · published 2026-10-16

Missing authorization check in Advanced Post Manager (4.5.6 and older)

Affected
4.5.6 and older
Fixed in
4.5.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Liquid Web / StellarWP Advanced Post Manager advanced-post-manager allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Advanced Post Manager: from n/a through 4.5.6.

NVD CVE-2026-111396Patchstack advisory

critical 9.8 CVE-2026-97283 · published 2026-10-05

PHP object injection in Advanced Post Manager (4.5.5 and older)

Affected
4.5.5 and older
Fixed in
4.5.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Liquid Web / StellarWP Advanced Post Manager advanced-post-manager allows Object Injection.This issue affects Advanced Post Manager: from n/a through 4.5.5.

NVD CVE-2026-97283Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Post Manager vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-post-manager"><img src="https://laskyr.com/plugins/advanced-post-manager/badge.svg" alt="Advanced Post Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit