Skip to content
Laskyr

Plugins · advanced-post-block · data as of 2026-11-04

Is Advanced Post Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.2)

As of 2026-11-04. 2 issues are on record for older versions; version 2.5.2 or newer fixes all of them that state a fix.

Latest version
2.5.2
Last updated
2026-10-26
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Advanced Post Block lets you add dynamic post grids, lists, sliders, and tickers. Filter content by category, tag, author, or custom post type. — by bPlugins

What to do

  1. Update to the latest version (2.5.2). Anything older than 2.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-post-block --field=version shows what you run; wp plugin update advanced-post-block updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-115955 · published 2026-10-26

Stored cross-site scripting (XSS) in Advanced Post Block (2.5.1 and older)

Affected
2.5.1 and older
Fixed in
2.5.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.

NVD CVE-2026-115955Patchstack advisory

medium 5.3 CVE-2024-0908 · published 2024-05-02

Missing authorization check in Advanced Post Block (1.13.4 and older)

Affected
1.13.4 and older
Fixed in
1.13.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Post Block – Display Posts, Pages, or Custom Posts on Your Page plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the apbPosts() function hooked via an AJAX action in all versions up to, and including, 1.13.4. This makes it possible for unauthenticated attackers to retrieve all post data, including those that may be password protected.

NVD CVE-2024-0908Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Post Block vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-post-block"><img src="https://laskyr.com/plugins/advanced-post-block/badge.svg" alt="Advanced Post Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit