Skip to content
Laskyr

Plugins · advanced-popups · data as of 2026-11-04

Is Advanced Popups safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.4)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.4 or newer fixes all of them that state a fix.

Latest version
1.2.4
Last updated
2026-07-11
Active installs
60,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.4+

Display high-converting newsletter popups, a cookie notice, or a notification with the light-weight yet feature-rich plugin. — by codesupplyco

What to do

  1. Update to the latest version (1.2.4). Anything older than 1.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-popups --field=version shows what you run; wp plugin update advanced-popups updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-11996 · published 2026-09-16

Stored cross-site scripting (XSS) in Advanced Popups (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
1.2.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'Notification Button Link' Field in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-11996Wordfence advisoryCode change (fix)

medium 4.3 CVE-2021-4421 · published 2023-07-12

Cross-site request forgery (CSRF) in Advanced Popups (1.1.1 and older)

Affected
1.1.1 and older
Fixed in
1.1.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Advanced Popups plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.1. This is due to missing or incorrect nonce validation on the metabox_popup_save() function. This makes it possible for unauthenticated attackers to save meta tags via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2021-4421Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Popups vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-popups"><img src="https://laskyr.com/plugins/advanced-popups/badge.svg" alt="Advanced Popups vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit