Skip to content
Laskyr

Plugins · advanced-partial-payment-or-deposit-for-woocommerce · data as of 2026-11-04

Is Advanced Partial Payment or Deposit for WooCom… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.31)

As of 2026-11-04. 2 issues are on record for older versions; version 4.0.12 or newer fixes all of them that state a fix.

Latest version
4.0.31
Last updated
2026-10-26
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Accept partial payments, deposits, and installments on your WooCommerce store. — by magepeopleteam

What to do

  1. Update to the latest version (4.0.31). Anything older than 4.0.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-partial-payment-or-deposit-for-woocommerce --field=version shows what you run; wp plugin update advanced-partial-payment-or-deposit-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-95589 · published 2026-10-09

Missing authorization check in Advanced Partial Payment or Deposit for WooCom… (4.0.1 and older)

Affected
4.0.1 and older
Fixed in
4.0.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Magepeople inc. Deposits and Partial Payments for WooCommerce advanced-partial-payment-or-deposit-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Deposits and Partial Payments for WooCommerce: from n/a through 4.0.1.

NVD CVE-2026-95589Patchstack advisory

medium 5.3 CVE-2026-27378 · published 2026-09-11

Missing authorization check in Advanced Partial Payment or Deposit for WooCom… (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
4.0.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Deposits and Partial Payments for WooCommerce <= 3.1.0 versions.

NVD CVE-2026-27378Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Partial Payment or Deposit for WooCom… vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-partial-payment-or-deposit-for-woocommerce"><img src="https://laskyr.com/plugins/advanced-partial-payment-or-deposit-for-woocommerce/badge.svg" alt="Advanced Partial Payment or Deposit for WooCom… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit