Skip to content
Laskyr

Plugins · advanced-nocaptcha-recaptcha · data as of 2026-11-04

Is CAPTCHA 4WP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.6.2)

As of 2026-11-04. 2 issues are on record for older versions; version 7.6.1 or newer fixes all of them that state a fix.

Latest version
7.6.2
Last updated
2026-08-25
Active installs
100,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Use CAPTCHA to stop spam and allow customers & users to interact with your website easily. Block fake accounts and orders. Avoid false positives. — by WPKube

What to do

  1. Update to the latest version (7.6.2). Anything older than 7.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-nocaptcha-recaptcha --field=version shows what you run; wp plugin update advanced-nocaptcha-recaptcha updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-32469 · published 2026-08-06

Security issue in CAPTCHA 4WP (7.6.0 and older)

Affected
7.6.0 and older
Fixed in
7.6.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in CAPTCHA 4WP <= 7.6.0 versions.

NVD CVE-2026-32469Patchstack advisory

high 8.8 CVE-2022-2184 · published 2022-08-01

Cross-site request forgery (CSRF) in CAPTCHA 4WP (older than 7.1.0)

Affected
older than 7.1.0
Fixed in
7.1.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The CAPTCHA 4WP WordPress plugin before 7.1.0 lets user input reach a sensitive require_once call in one of its admin-side templates. This can be abused by attackers, via a Cross-Site Request Forgery attack to run arbitrary code on the server.

NVD CVE-2022-2184WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CAPTCHA 4WP vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-nocaptcha-recaptcha"><img src="https://laskyr.com/plugins/advanced-nocaptcha-recaptcha/badge.svg" alt="CAPTCHA 4WP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit