Skip to content
Laskyr

Plugins · advanced-ip-blocker · data as of 2026-11-04

Is Advanced IP Blocker safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.13.23)

As of 2026-11-04. 2 issues are on record for older versions; version 8.13.14 or newer fixes all of them that state a fix.

Latest version
8.13.23
Last updated
2026-10-31
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

A complete WordPress security firewall: blocks IPs, bots, countries & ASN. Includes an intelligent WAF, Threat Scoring, Geo-Challenge, and 2FA. — by IniLerm

What to do

  1. Update to the latest version (8.13.23). Anything older than 8.13.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-ip-blocker --field=version shows what you run; wp plugin update advanced-ip-blocker updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-104732 · published 2026-10-10

Authentication bypass in Advanced IP Blocker (8.13.13 and older)

Affected
8.13.13 and older
Fixed in
8.13.14 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced IP Blocker plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 8.13.13 The vulnerability exists because `handle_login_action()` performs no server-side check — via transient, session marker, or equivalent — that a requester completed step-1 password authentication before processing a step-2 TOTP submission for the POSTed `user_id`; compounding this, an error branch in the function unconditionally mints a fresh `advaipbl-2fa-interim-{user_id}` nonce and delivers it in a `Location` header to any unauthenticated caller, after which `display_2fa_login_form_step_2()` renders a valid `advaipbl-2fa-verify-{user_id}` nonce in HTML — both nonces computed against a fixed `uid=0` empty-session context and therefore fully reusable by the attacker across subsequent requests. This makes it possible for unauthenticated attackers to bypass authentication entirely for any 2FA-enabled account, including administrators, by brute-forcing an unthrottled 6-digit TOTP code (no attempt counter, no account lockout, and no `wp_login_failed` firing) and receiving a fully authenticated session cookie via `wp_set_auth_cookie` without ever supplying the account password, resulting in complete site takeover. Exploitation requires only a known `user_id` for an account that has the plugin's 2FA feature enabled.

NVD CVE-2026-104732Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-42739 · published 2026-05-27

Cross-site scripting (XSS) in Advanced IP Blocker (8.10.7 and older)

Affected
8.10.7 and older
Fixed in
8.10.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in IniLerm Advanced IP Blocker advanced-ip-blocker allows DOM-Based XSS.This issue affects Advanced IP Blocker: from n/a through <= 8.10.7.

NVD CVE-2026-42739Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced IP Blocker vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-ip-blocker"><img src="https://laskyr.com/plugins/advanced-ip-blocker/badge.svg" alt="Advanced IP Blocker vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit