Plugins · advanced-import · data as of 2026-11-04
Is Advanced Import safe? Known vulnerabilities and latest version
- Latest version
- 2.0.0
- Last updated
- 2026-06-09
- Active installs
- 80,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Easily import demo data including posts, pages, media, widgets, customizer settings, and Gutenberg Blocks. — by AddonsPress
What to do
- Update to the latest version (2.0.0). Anything older than 2.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get advanced-import --field=version shows what you run; wp plugin update advanced-import updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-4328 · published 2026-06-19
Cross-site scripting (XSS) in Advanced Import (1.4.6 and older)
- Affected
- 1.4.6 and older
- Fixed in
- 2.0.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Advanced Import plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.4.6. This is due to the plugin using wp_remote_get() to fetch a user-supplied URL without validating that the URL does not point to internal or private network resources in the demo_download_and_unzip() function. The 'demo_file' parameter from $_POST is passed through sanitize_text_field() (which only handles XSS-related sanitization) and then directly into wp_remote_get() when 'demo_file_type' is set to 'url'. Notably, the plugin uses wp_safe_remote_get() in other locations (theme template libraries) which would provide SSRF protection, but fails to use it in this critical AJAX handler. This makes it possible for authenticated attackers, with Author-level access and above (upload_files capability), to make web requests to arbitrary locations originating from the web application, which can be used to query and view data from internal services, including cloud instance metadata endpoints.
NVD CVE-2026-4328Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2022-3677 · published 2022-12-05
Cross-site request forgery (CSRF) in Advanced Import (older than 1.3.8)
- Affected
- older than 1.3.8
- Fixed in
- 1.3.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Advanced Import WordPress plugin before 1.3.8 does not have CSRF check when installing and activating plugins, which could allow attackers to make a logged in admin install arbitrary plugins from WordPress.org, and activate arbitrary ones from the blog via CSRF attacks
Recent activity
- 2026-06-09 — latest release on wordpress.org (2.0.0).
- 2026-06-19 — Cross-site scripting (XSS) disclosed (CVE-2026-4328), fixed in 2.0.0.
- 2022-12-05 — Cross-site request forgery (CSRF) disclosed (CVE-2022-3677), fixed in 1.3.8.
Get an email when Advanced Import has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Advanced Import (advanced-import) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/advanced-import (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/advanced-import"><img src="https://laskyr.com/plugins/advanced-import/badge.svg" alt="Advanced Import vulnerability status"></a>