Skip to content
Laskyr

Plugins · advanced-forms · data as of 2026-11-04

Is Advanced Forms for ACF safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.3.8)

As of 2026-11-04. 2 issues are on record for older versions; version 1.9.3.8 or newer fixes all of them that state a fix.

Latest version
1.9.3.8
Last updated
2026-05-11
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.1+

Flexible and developer-friendly forms using the power of Advanced Custom Fields — by Phil Kurth

What to do

  1. Update to the latest version (1.9.3.8). Anything older than 1.9.3.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-forms --field=version shows what you run; wp plugin update advanced-forms updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-57378 · published 2026-07-13

Missing authorization check in Advanced Forms for ACF (1.9.3.7 and older)

Affected
1.9.3.7 and older
Fixed in
1.9.3.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Phil Kurth Advanced Forms advanced-forms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Advanced Forms: from n/a through <= 1.9.3.7.

NVD CVE-2026-57378Patchstack advisory

medium 5.3 CVE-2024-1121 · published 2024-02-05

Missing authorization check in Advanced Forms for ACF (1.9.3.2 and older)

Affected
1.9.3.2 and older
Fixed in
1.9.3.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Advanced Forms for ACF plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the export_json_file() function in all versions up to, and including, 1.9.3.2. This makes it possible for unauthenticated attackers to export form settings.

NVD CVE-2024-1121Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Forms for ACF vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-forms"><img src="https://laskyr.com/plugins/advanced-forms/badge.svg" alt="Advanced Forms for ACF vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit