Skip to content
Laskyr

Plugins · advanced-custom-fields-font-awesome · data as of 2026-11-04

Is Advanced Custom Fields safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.2.0)

As of 2026-11-04. 4 issues are on record for older versions; version 6.1.2 or newer fixes all of them that state a fix.

Latest version
6.2.0
Last updated
2026-08-25
Active installs
90,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Adds a new 'Font Awesome Icon' field to the popular Advanced Custom Fields plugin. — by Justin Kruit

What to do

  1. Update to the latest version (6.2.0). Anything older than 6.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get advanced-custom-fields-font-awesome --field=version shows what you run; wp plugin update advanced-custom-fields-font-awesome updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-66678 · published 2026-08-06

Missing authorization check in Advanced Custom Fields (6.1.1 and older)

Affected
6.1.1 and older
Fixed in
6.1.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Broken Access Control in Advanced Custom Fields: Font Awesome Field <= 6.1.1 versions.

NVD CVE-2026-66678Patchstack advisory

medium 6.5 CVE-2026-49044 · published 2026-05-27

Stored cross-site scripting (XSS) in Advanced Custom Fields (5.0.2 and older)

Affected
5.0.2 and older
Fixed in
6.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Justin Kruit Advanced Custom Fields: Font Awesome Field allows Stored XSS. This issue affects Advanced Custom Fields: Font Awesome Field: from n/a through 5.0.2.

NVD CVE-2026-49044Patchstack advisory

medium 6.4 CVE-2026-6415 · published 2026-05-15

Stored cross-site scripting (XSS) in Advanced Custom Fields (5.0.2 and older)

Affected
5.0.2 and older
Fixed in
6.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Custom Fields: Font Awesome plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to and including 5.0.2. This is due to insufficient input validation of JSON field values and unsafe client-side HTML construction in the update_preview() JavaScript function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-6415Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-14983 · published 2026-02-19

Cross-site scripting (XSS) in Advanced Custom Fields (5.0.1 and older)

Affected
5.0.1 and older
Fixed in
5.0.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Custom Fields: Font Awesome Field plugin for WordPress is vulnerable to Cross-Site Scripting in all versions up to, and including, 5.0.1 due to insufficient input sanitization and output escaping. This makes it possible forauthenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts that execute in a victim's browser.

NVD CVE-2025-14983Wordfence advisoryCode change (fix)plugins.svn.wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Custom Fields vulnerability status badge
<a href="https://laskyr.com/plugins/advanced-custom-fields-font-awesome"><img src="https://laskyr.com/plugins/advanced-custom-fields-font-awesome/badge.svg" alt="Advanced Custom Fields vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit