Plugins · advanced-coupons-for-woocommerce-free · data as of 2026-11-04
Is Advanced Coupons for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.7.6.1
- Last updated
- 2026-10-28
- Active installs
- 20,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
WooCommerce coupon plugin for BOGO deals, store credit, URL coupons, discount codes, coupon rules, gift cards & loyalty program. Free & powerful. — by Josh Kohlbach
What to do
- Update to the latest version (4.7.6.1). Anything older than 4.7.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get advanced-coupons-for-woocommerce-free --field=version shows what you run; wp plugin update advanced-coupons-for-woocommerce-free updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-39508 · published 2026-04-08
Cross-site scripting (XSS) in Advanced Coupons for WooCommerce (4.7.1.1 and older)
- Affected
- 4.7.1.1 and older
- Fixed in
- 4.7.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Josh Kohlbach Advanced Coupons for WooCommerce Coupons advanced-coupons-for-woocommerce-free allows DOM-Based XSS.This issue affects Advanced Coupons for WooCommerce Coupons: from n/a through <= 4.7.1.1.
medium 4.3 CVE-2026-31919 · published 2026-03-13
Missing authorization check in Advanced Coupons for WooCommerce (4.7.1 and older)
- Affected
- 4.7.1 and older
- Fixed in
- 4.7.1.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Josh Kohlbach Advanced Coupons for WooCommerce Coupons advanced-coupons-for-woocommerce-free allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Advanced Coupons for WooCommerce Coupons: from n/a through <= 4.7.1.
high 7.6 CVE-2025-62015 · published 2025-10-22
SQL injection in Advanced Coupons for WooCommerce (4.6.8 and older)
- Affected
- 4.6.8 and older
- Fixed in
- 4.6.9
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Josh Kohlbach Advanced Coupons for WooCommerce Coupons advanced-coupons-for-woocommerce-free.This issue affects Advanced Coupons for WooCommerce Coupons: from n/a through <= 4.6.8.
medium 4.3 CVE-2022-43481 · published 2022-11-08
Cross-site request forgery (CSRF) in Advanced Coupons for WooCommerce (4.5 and older)
- Affected
- 4.5 and older
- Fixed in
- 4.5.0.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Advanced Coupons for WooCommerce Coupons plugin <= 4.5 on WordPress leading to notice dismissal.
Recent activity
- 2026-10-28 — latest release on wordpress.org (4.7.6.1).
- 2026-04-08 — Cross-site scripting (XSS) disclosed (CVE-2026-39508), fixed in 4.7.2.
- 2026-03-13 — Missing authorization check disclosed (CVE-2026-31919), fixed in 4.7.1.1.
- 2025-10-22 — SQL injection disclosed (CVE-2025-62015), fixed in 4.6.9.
Get an email when Advanced Coupons for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Advanced Coupons for WooCommerce (advanced-coupons-for-woocommerce-free) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Josh Kohlbach (5 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · SQL injection (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/advanced-coupons-for-woocommerce-free (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/advanced-coupons-for-woocommerce-free"><img src="https://laskyr.com/plugins/advanced-coupons-for-woocommerce-free/badge.svg" alt="Advanced Coupons for WooCommerce vulnerability status"></a>