Plugins · advanced-country-blocker · data as of 2026-11-04
Is Advanced Country Blocker safe? Known vulnerabilities and latest version
- Latest version
- 2.3.2
- Last updated
- 2026-02-06
- Active installs
- 2,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.2+
An advanced security plugin that blocks website visitors by country, with additional features like blacklisting, logging blocked attempts, admin bypas … — by brstefanovic
What to do
- Update to the latest version (2.3.2). Anything older than 2.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get advanced-country-blocker --field=version shows what you run; wp plugin update advanced-country-blocker updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-1675 · published 2026-02-07
Security issue in Advanced Country Blocker (2.3.1 and older)
- Affected
- 2.3.1 and older
- Fixed in
- 2.3.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Advanced Country Blocker plugin for WordPress is vulnerable to Authorization Bypass in all versions up to, and including, 2.3.1 due to the use of a predictable default value for the secret bypass key created during installation without requiring users to change it. This makes it possible for unauthenticated attackers to bypass the geolocation blocking mechanism by appending the key to any URL on sites where the administrator has not changed the default value.
NVD CVE-2026-1675Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-02-06 — latest release on wordpress.org (2.3.2).
- 2026-02-07 — Security issue disclosed (CVE-2026-1675), fixed in 2.3.2.
Get an email when Advanced Country Blocker has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Advanced Country Blocker (advanced-country-blocker) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/advanced-country-blocker (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/advanced-country-blocker"><img src="https://laskyr.com/plugins/advanced-country-blocker/badge.svg" alt="Advanced Country Blocker vulnerability status"></a>