Plugins · advanced-classifieds-and-directory-pro · data as of 2026-11-04
Is Advanced Classifieds & Directory Pro safe? Known vulnerabilities and latest version
- Latest version
- 3.5.1
- Last updated
- 2026-10-17
- Active installs
- 2,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6.20+
Build any kind of directory site: classifieds, cars, bikes & other vehicles dealers site, pets, real estate portal, yellow pages, etc... — by pluginsware
What to do
- Update to the latest version (3.5.1). Anything older than 3.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get advanced-classifieds-and-directory-pro --field=version shows what you run; wp plugin update advanced-classifieds-and-directory-pro updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-93883 · published 2026-10-10
Stored cross-site scripting (XSS) in Advanced Classifieds & Directory Pro (3.4.4 and older)
- Affected
- 3.4.4 and older
- Fixed in
- 3.5.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Advanced Classifieds & Directory Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'phone' parameter in all versions up to, and including, 3.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable on sites where the 'Force Bootstrap' miscellaneous setting (acadp_misc_settings['force_bootstrap']) is enabled and the 'ACADP Listing Address' widget is placed on a sidebar displayed on single listing pages; both conditions are non-default.
NVD CVE-2026-93883Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-19074 · published 2026-08-10
Information disclosure in Advanced Classifieds & Directory Pro (older than 3.4.3)
- Affected
- older than 3.4.3
- Fixed in
- 3.4.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Advanced Classifieds & Directory Pro Advanced Classifieds & Directory Pro WordPress plugin before 3.4.3 (<= 3.4.2) is vulnerable to unauthenticated sensitive information exposure via the AJAX action `acadp_public_custom_fields_listings`.
medium 4.3 CVE-2025-68580 · published 2025-12-24
Cross-site request forgery (CSRF) in Advanced Classifieds & Directory Pro (3.2.9 and older)
- Affected
- 3.2.9 and older
- Fixed in
- 3.3.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in pluginsware Advanced Classifieds & Directory Pro advanced-classifieds-and-directory-pro allows Cross Site Request Forgery.This issue affects Advanced Classifieds & Directory Pro: from n/a through <= 3.2.9.
high 8.5 CVE-2024-37501 · published 2024-07-09
Path traversal / file read in Advanced Classifieds & Directory Pro (3.1.3 and older)
- Affected
- 3.1.3 and older
- Fixed in
- 3.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in PluginsWare Advanced Classifieds & Directory Pro allows Path Traversal.This issue affects Advanced Classifieds & Directory Pro: from n/a through 3.1.3.
medium 4.3 CVE-2024-2222 · published 2024-04-09
Missing authorization check in Advanced Classifieds & Directory Pro (3.0.0 and older)
- Affected
- 3.0.0 and older
- Fixed in
- 3.1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Advanced Classifieds & Directory Pro plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the ajax_callback_delete_attachment function in all versions up to, and including, 3.0.0. This makes it possible for authenticated attackers, with subscriber access or higher, to delete arbitrary media uploads.
NVD CVE-2024-2222Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-17 — latest release on wordpress.org (3.5.1).
- 2026-10-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-93883), fixed in 3.5.0.
- 2026-08-10 — Information disclosure disclosed (CVE-2026-19074), fixed in 3.4.3.
- 2025-12-24 — Cross-site request forgery (CSRF) disclosed (CVE-2025-68580), fixed in 3.3.0.
Get an email when Advanced Classifieds & Directory Pro has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Advanced Classifieds & Directory Pro (advanced-classifieds-and-directory-pro) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Sensitive data exposure (1) · Cross-site request forgery (CSRF) (1) · Path traversal and file read (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/advanced-classifieds-and-directory-pro (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/advanced-classifieds-and-directory-pro"><img src="https://laskyr.com/plugins/advanced-classifieds-and-directory-pro/badge.svg" alt="Advanced Classifieds & Directory Pro vulnerability status"></a>