Plugins · advanced-access-manager · data as of 2026-11-04
Is Access Governance for WordPress (aka AAM) safe? Known vulnerabilities and latest version
- Latest version
- 8.0.2
- Last updated
- 2026-10-19
- Active installs
- 100,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Access Governance for WordPress. Understand, control, and continuously govern who and what can access your WordPress website. — by AAM Plugin
What to do
- Update to the latest version (8.0.2). Anything older than 7.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get advanced-access-manager --field=version shows what you run; wp plugin update advanced-access-manager updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-42674 · published 2026-06-01
Authentication bypass in Access Governance for WordPress (aka AAM) (7.1.0 and older)
- Affected
- 7.1.0 and older
- Fixed in
- 7.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authentication Bypass by Spoofing vulnerability in AAM Plugin Advanced Access Manager allows URL Encoding. This issue affects Advanced Access Manager: from n/a through 7.1.0.
high 7.5 CVE-2019-25213 · published 2024-10-16
Path traversal / file read in Access Governance for WordPress (aka AAM) (older than 5.9.9)
- Affected
- older than 5.9.9
- Fixed in
- 5.9.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Advanced Access Manager plugin for WordPress is vulnerable to Unauthenticated Arbitrary File Read in versions up to, and including, 5.9.8.1 due to insufficient validation on the aam-media parameter. This allows unauthenticated attackers to read any file on the server, including sensitive files such as wp-config.php
medium 5.9 CVE-2024-29124 · published 2024-03-19
Stored cross-site scripting (XSS) in Access Governance for WordPress (aka AAM) (6.9.20 and older)
- Affected
- 6.9.20 and older
- Fixed in
- 6.9.21
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AAM Advanced Access Manager allows Stored XSS.This issue affects Advanced Access Manager: from n/a through 6.9.20.
medium 6.1 CVE-2024-29127 · published 2024-03-19
Reflected cross-site scripting (XSS) in Access Governance for WordPress (aka AAM) (6.9.20 and older)
- Affected
- 6.9.20 and older
- Fixed in
- 6.9.21
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AAM Advanced Access Manager allows Reflected XSS.This issue affects Advanced Access Manager: from n/a through 6.9.20.
medium 5.4 CVE-2023-51674 · published 2024-02-01
Stored cross-site scripting (XSS) in Access Governance for WordPress (aka AAM) (6.9.18 and older)
- Affected
- 6.9.18 and older
- Fixed in
- 6.9.19
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More allows Stored XSS.This issue affects Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: from n/a through 6.9.18.
medium 5.4 CVE-2023-51675 · published 2023-12-29
Open redirect in Access Governance for WordPress (aka AAM) (6.9.18 and older)
- Affected
- 6.9.18 and older
- Fixed in
- 6.9.19
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More.This issue affects Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: from n/a through 6.9.18.
medium 5.4 CVE-2023-50881 · published 2023-12-29
Stored cross-site scripting (XSS) in Access Governance for WordPress (aka AAM) (6.9.15 and older)
- Affected
- 6.9.15 and older
- Fixed in
- 6.9.16
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More allows Stored XSS.This issue affects Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: from n/a through 6.9.15.
Recent activity
- 2026-10-19 — latest release on wordpress.org (8.0.2).
- 2026-06-01 — Authentication bypass disclosed (CVE-2026-42674), fixed in 7.1.1.
- 2024-10-16 — Path traversal / file read disclosed (CVE-2019-25213), fixed in 5.9.9.
- 2024-03-19 — Stored cross-site scripting (XSS) disclosed (CVE-2024-29124), fixed in 6.9.21.
Get an email when Access Governance for WordPress (aka AAM) has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Access Governance for WordPress (aka AAM) (advanced-access-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Authentication bypass (1) · Path traversal and file read (1) · Open redirect (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/advanced-access-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/advanced-access-manager"><img src="https://laskyr.com/plugins/advanced-access-manager/badge.svg" alt="Access Governance for WordPress (aka AAM) vulnerability status"></a>