Plugins · adsensei-b30 · data as of 2026-11-04
Is Adsmonetizer safe? Known vulnerabilities and latest version
- Status
- Closed 2025-02-16
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate adsensei-b30 && wp plugin delete adsensei-b30
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
high 7.1 CVE-2025-15643 · published 2026-10-05
Reflected cross-site scripting (XSS) in Adsmonetizer (3.2.4 and older)
- Affected
- 3.2.4 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jose Fernandez Adsmonetizer adsensei-b30 allows Reflected XSS.This issue affects Adsmonetizer: from n/a through 3.2.4.
medium 6.1 CVE-2024-1437 · published 2024-02-29
Reflected cross-site scripting (XSS) in Adsmonetizer (3.1.2 and older)
- Affected
- 3.1.2 and older
- Fixed in
- 3.1.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in José Fernandez Adsmonetizer allows Reflected XSS.This issue affects Adsmonetizer: from n/a through 3.1.2.
Recent activity
- 2025-02-16 — closed on wordpress.org (Security Issue).
- 2026-10-05 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-15643), fix version not stated.
- 2024-02-29 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-1437), fixed in 3.1.3.
Get an email when Adsmonetizer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Adsmonetizer (adsensei-b30) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/adsensei-b30 (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/adsensei-b30"><img src="https://laskyr.com/plugins/adsensei-b30/badge.svg" alt="Adsmonetizer vulnerability status"></a>