Plugins · adminify · data as of 2026-11-04
Is Adminify safe? Known vulnerabilities and latest version
- Latest version
- 4.3.3
- Last updated
- 2026-10-12
- Active installs
- 6,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
White label WordPress admin, admin menu editor, login page customizer, admin dark mode, media library folders, admin columns. — by Pixar Labs
What to do
- Update to the latest version (4.3.3). Anything older than 4.2.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get adminify --field=version shows what you run; wp plugin update adminify updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 2.7 CVE-2026-11781 · published 2026-07-02
Security issue in Adminify (older than 4.2.10)
- Affected
- older than 4.2.10
- Fixed in
- 4.2.10
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Adminify WordPress plugin before 4.2.10 does not perform per-user read-capability checks on the results returned by one of its administration search features, allowing users with a low-privilege role (Contributor) to disclose non-public content that WordPress would not otherwise expose to them, such as other authors' unpublished post titles, pending comment content, the site's Adminify WordPress plugin before 4.2.10 inventory, and user account names.
medium 5.3 CVE-2026-1060 · published 2026-01-28
Information disclosure in Adminify (4.0.7.7 and older)
- Affected
- 4.0.7.7 and older
- Fixed in
- 4.0.7.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Adminify plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.0.7.7 via the /wp-json/adminify/v1/get-addons-list REST API endpoint. The endpoint is registered with permission_callback set to __return_true, allowing unauthenticated attackers to retrieve the complete list of available addons, their installation status, version numbers, and download URLs.
NVD CVE-2026-1060Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-68592 · published 2025-12-24
Missing authorization check in Adminify (4.0.6.1 and older)
- Affected
- 4.0.6.1 and older
- Fixed in
- 4.0.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Liton Arefin WP Adminify adminify allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Adminify: from n/a through <= 4.0.6.1.
medium 5.4 CVE-2025-68593 · published 2025-12-24
Missing authorization check in Adminify (4.0.6.1 and older)
- Affected
- 4.0.6.1 and older
- Fixed in
- 4.0.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Liton Arefin WP Adminify adminify allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Adminify: from n/a through <= 4.0.6.1.
medium 6.4 CVE-2024-8959 · published 2024-10-24
Stored cross-site scripting (XSS) in Adminify (4.0.1.6 and older)
- Affected
- 4.0.1.6 and older
- Fixed in
- 4.0.1.6.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Adminify – Custom WordPress Dashboard, Login and Admin Customizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 4.0.1.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
NVD CVE-2024-8959Wordfence advisoryCode change (fix)wordpress.orgwpadminify.com
high 7.2 CVE-2023-52132 · published 2023-12-31
SQL injection in Adminify (3.1.6 and older)
- Affected
- 3.1.6 and older
- Fixed in
- 3.1.7
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Jewel Theme WP Adminify.This issue affects WP Adminify: from n/a through 3.1.6.
medium 4.8 CVE-2023-44266 · published 2023-10-02
Stored cross-site scripting (XSS) in Adminify (3.1.6 and older)
- Affected
- 3.1.6 and older
- Fixed in
- 3.1.7 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Jewel Theme WP Adminify plugin <= 3.1.6 versions.
Recent activity
- 2026-10-12 — latest release on wordpress.org (4.3.3).
- 2026-07-02 — Security issue disclosed (CVE-2026-11781), fixed in 4.2.10.
- 2026-01-28 — Information disclosure disclosed (CVE-2026-1060), fixed in 4.0.7.8.
- 2025-12-24 — Missing authorization check disclosed (CVE-2025-68592), fixed in 4.0.7.
Get an email when Adminify has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Adminify (adminify) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Pixar Labs (2 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2) · Sensitive data exposure (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/adminify (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/adminify"><img src="https://laskyr.com/plugins/adminify/badge.svg" alt="Adminify vulnerability status"></a>