Plugins · admin-safety-guard · data as of 2026-11-04
Is Admin Safety Guard safe? Known vulnerabilities and latest version
- Latest version
- 1.4.1
- Last updated
- 2026-08-13
- Active installs
- 20+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 8.0+
Stop brute force attacks for free. Limit login attempts, add 2FA and reCAPTCHA, hide wp-login.php, block IPs and see every login on your site. — by wordpressdirect
What to do
- Update to the latest version (1.4.1). Anything older than 1.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get admin-safety-guard --field=version shows what you run; wp plugin update admin-safety-guard updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-16578 · published 2026-08-08
Information disclosure in Admin Safety Guard (1.2.7 up to (not including) 1.4.0)
- Affected
- 1.2.7 up to (not including) 1.4.0
- Fixed in
- 1.4.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Admin Safety Guard — Login Security, Limit Logins, 2FA & Brute Force Protection WordPress plugin before 1.4.0 does not perform any capability check on one of its REST API endpoints, allowing unauthenticated attackers to retrieve the full list of registered users including their usernames, email addresses, roles, and two-factor authentication enrollment status.
high 8.1 CVE-2026-25471 · published 2026-03-19
Authentication bypass in Admin Safety Guard (1.2.6 and older)
- Affected
- 1.2.6 and older
- Fixed in
- 1.2.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authentication Bypass Using an Alternate Path or Channel vulnerability in Themepaste Admin Safety Guard admin-safety-guard allows Password Recovery Exploitation.This issue affects Admin Safety Guard: from n/a through <= 1.2.6.
Recent activity
- 2026-08-13 — latest release on wordpress.org (1.4.1).
- 2026-08-08 — Information disclosure disclosed (CVE-2026-16578), fixed in 1.4.0.
- 2026-03-19 — Authentication bypass disclosed (CVE-2026-25471), fixed in 1.2.7.
Get an email when Admin Safety Guard has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Admin Safety Guard (admin-safety-guard) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/admin-safety-guard (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/admin-safety-guard"><img src="https://laskyr.com/plugins/admin-safety-guard/badge.svg" alt="Admin Safety Guard vulnerability status"></a>