Skip to content
Laskyr

Plugins · admin-menu-editor · data as of 2026-11-01

Is Admin Menu Editor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.15.2)

As of 2026-11-01. 4 issues are on record for older versions; version 1.15 or newer fixes all of them that state a fix.

Latest version
1.15.2
Last updated
2026-08-19
Active installs
300,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Lets you edit the WordPress admin menu. You can re-order, hide or rename menus, add custom menus and more. — by Janis Elsts

What to do

  1. Update to the latest version (1.15.2). Anything older than 1.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get admin-menu-editor --field=version shows what you run; wp plugin update admin-menu-editor updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-32456 · published 2026-03-13

Cross-site request forgery (CSRF) in Admin Menu Editor (1.14.1 and older)

Affected
1.14.1 and older
Fixed in
1.15
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Janis Elsts Admin Menu Editor admin-menu-editor allows Cross Site Request Forgery.This issue affects Admin Menu Editor: from n/a through <= 1.14.1.

NVD CVE-2026-32456Patchstack advisory

medium 6.4 CVE-2025-9493 · published 2025-09-06

Stored cross-site scripting (XSS) in Admin Menu Editor (1.14 and older)

Affected
1.14 and older
Fixed in
1.14.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Admin Menu Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘placeholder’ parameter in all versions up to, and including, 1.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9493Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 8.8 CVE-2024-24876 · published 2024-02-21

Cross-site request forgery (CSRF) in Admin Menu Editor (1.12 and older)

Affected
1.12 and older
Fixed in
1.12.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Janis Elsts Admin Menu Editor.This issue affects Admin Menu Editor: from n/a through 1.12.

NVD CVE-2024-24876Patchstack advisory

medium 6.1 CVE-2022-0625 · published 2022-05-09

Reflected cross-site scripting (XSS) in Admin Menu Editor (1.0.4 to 1.0.4)

Affected
1.0.4 to 1.0.4
Fixed in
1.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Admin Menu Editor WordPress plugin through 1.0.4 does not sanitize and escape a parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting.

NVD CVE-2022-0625WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Admin Menu Editor vulnerability status badge
<a href="https://laskyr.com/plugins/admin-menu-editor"><img src="https://laskyr.com/plugins/admin-menu-editor/badge.svg" alt="Admin Menu Editor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit